Much faster way to add Rclone mount to Plex

I've been doing some tests with Rclone mount + Plex and I noticed Plex takes A LOT of time when you add a new mounted remote with a few hundred GB and lots of files and that's because it reads chunks from all the files to get info about video/audio formats, etc.

Maybe there's an easier way to avoid that but the solution I came up is to generate mockup files, add them to Plex, and after it scans point it to the real server

In Windows, you can do it like this

  1. open powershell and generate the files
    (this will create the folder 'Movies' with 1 byte files in the same subpaths as the original files)
.\rclone.exe lsjson -R drive:Movies | ConvertFrom-Json | Where -not IsDir | Select Path | New-Item -Path {'Movies/'+$_.Path} -Force -Value 0
  1. mount the Movies folder as a disk with
.\rclone.exe mount .\Movies\ P:
  1. add P: as a new Plex Library, and after it matches everything

  2. close the previous mount and mount the real server to the same drive letter

.\rclone.exe mount drive:Movies P: --read-only

All your files will be added as No Audio and No Video.

The first time you try to play anything it should read the chunks you skipped before to fill the media info for that specific file only. You will get an error the first time depending on the player. Try again and it should work.

Plex Web sometimes shows the wand icon for stuff you played, like its trying to update metadata but it seems to never complete. After you restart the server it goes away.

And that's it! maybe there's a better solution based on the same idea but this is working really well for me. If I'm missing anything obvious about Rclone or Plex please let me know :slight_smile:

1 Like

@VBB, given your recent post , what do you think?

1 Like

Funny, I was just thinking about asking the Plex guys to implement an option to disable media analysis entirely on the initial scan. That would solve a lot of problems.

OP here is correct about how it works on first play. That's why this should be doable.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.