Moving sub folder issue

What is the problem you are having with rclone?

I am trying to move sub directories containing the word "Featurettes"

The issue I Am having is rclone is recreating all directories whether they contain a folder with the name or not. Meaning thousands of empty folders will be made

Run the command 'rclone version' and share the full output of the command.

rclone v1.66.0

  • os/version: Microsoft Windows Server 2022 Datacenter Evaluation 21H2 (64 bit)
  • os/kernel: 10.0.20348.2402 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.22.1
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone -vP --transfers=100 --drive-use-trash=false --delete-empty-src-dirs --ignore-case --include **/*Featurettes*/** move  Source:/ Destination:/Featurettes.TV/ --config=drives3.conf

My goal is to only have rclone create the parent folders that contain a sub folder with "Featurettes" and move the contents of those folders. It does this fine, but as I said it is creating every folder in root.

Which means I would have to run another cmd to remove the empty directories.

Is there a trick or something I am missing to tell it to skip creating empty directories in Destination?

Also I notice using the --transfers=100 flag appears not to work with the includes, is there anyway do this in parallel?

the latest version introduced a bug/feature that broke backwards compatibility.

so you have a few options:

  • might try --no-update-dir-modtime
  • use the latest beta. which i believe reverts back to the old behavior.
  • use last stable version, v1.65.2 - this is what i continue to do.

Thanks, will give v1.65.2 a try and see how that goes

Just realized though maybe I am doing the includes wrong, can you verify for me?

I am using this

--include **/*Featurettes*/**

Just realized though that using that would include any folder name with Featurettes in it, so would this be the proper way here?..

--include **/Featurettes/**

the --include *Featurettes* is wild card in directory name right? So if want to make sure this is only getting a directory Exactly named the same I remove the * around the folder name right?

Just want to clarify if my thinking is right

the safest, easiest way to test a filter is using rclone ls
that way you can verify for yourself.