Mountpoint "X:" didn't became available on mount (Windows 10)


#1

When I try to shutdown and then later restart rclone on Windows 10, the mount drive usually doesn’t show up correctly, with the following error in the log:

“mountpoint “X:” didn’t became available on mount. Continuing anyway.”

In the Task Manager, I didn’t see rclone anymore after I shutdown rclone. Besides, I tried to restart Windows Explorer in task message but it didn’t help. Only way to consistently solve it is to restart Windows.

Any idea what could cause this issue or how to solve it without restarting Windows? Currently rclone mount on Windows has a bug that made remote folders invisible after a while. Therefore restarting rclone is necessary every now and then.

Thank you in advance!


#2

Are you using the latest version of WinFSP?

Which version of rclone are you using?

How do you start and shutdown rclone? With a script or something else?


#3

Yes. I just downloaded and installed rclone (1.39 amd64) and WinFSP (winfsp-1.2.17346.msi) last week. Therefore they are the latest versions.

To start rclone, I used a .bat with administrator privilege. To be exact, the following is the command in the BAT. Basically it starts rclone.exe and put it in the second virtual desktop on Windows:

“D:\Program Files (x86)\VDesk\vdesk.exe” on:2 noswitch:true run:“C:\Program Files\rclone\rclone.exe” mount Seeding: X: --config=“C:\Program Files\rclone\rclone.conf” --no-checksum --allow-other --no-modtime --buffer-size=100M --bwlimit=8500 --cache-dir=D:\Temp\rclone\ --max-read-ahead=10M --dir-cache-time=240h --cache-read-retries=3 --cache-chunk-size=10M --cache-total-chunk-size=30G --cache-info-age=24h --cache-db-purge --cache-chunk-path=D:\Temp\rclone\ --cache-db-path=D:\Temp\rclone\ --cache-chunk-clean-interval=1h --cache-workers=4 --cache-rps=4 --tpslimit=4 --low-level-retries=10 --log-file=D:\Temp\rclone\rclone.log -v

(What vdesk.exe did is simply launch the program with the parameters and move it to the second virtual desktop. You may ignore that part. For rclone parameter, the value of --dir-cache-time=240h is extremely high to delay the missing folder bug in Windows from happening. I was unable to re-start rclone when setting it at a low value though.)

To shutdown rclone, I close the program window.

Please kindly advise if anything I did/configure is suspicious.

I just changed to use nsmm to install rclone as a service on Windows yesterday.

Thank you so much ncw for the great program and your reply!!


#4

After using nssm to start rclone as a Windows service, I don’t encounter the problem anymore!
I can use services.msc to start/stop/start/stop the rclone service without getting the error message.

My guess is, the problem I encountered was due to some kind of user account vs. administrative account issue on Windows. I do not know why such issue could make an already closed drive letter became unavailable, but somehow using the system account to start rclone seems to have solved this issue anyway.

I will continue testing. In case the problem happens again I will report with more details.


#5

Ouch. After running rclone for a day, the problem happened again, although the rclone on Windows 10 is started by system account. In order to clear the folder cache, I stopped the server and then tried to start it 20 seconds later. It showed the same error again. Only way to get the mountpoint again is to restart the computer.

Is it possibly due to my setting the long --dir-cache-time=240h ?

Here is the log with my comment in []:

[The first lines are some error message before the restart. I assume they are normal as my upload bandwidth were heavily occupied at that time.]

2018/01/28 00:28:00 ERROR : Huge/Out.1.noli.me.tangere.1971.BluRay.Remux.1080p.AVC.FLAC1.0-BMF/Out.1.noli.me.tangere.1971.E08.BluRay.Remux.1080p.AVC.FLAC1.0-BMF.mkv: (9290383360/16319859390) error (chunk not found 9290383360) response
2018/01/28 00:28:05 ERROR : Huge/Out.1.noli.me.tangere.1971.BluRay.Remux.1080p.AVC.FLAC1.0-BMF/Out.1.noli.me.tangere.1971.E08.BluRay.Remux.1080p.AVC.FLAC1.0-BMF.mkv: (9290383360/16319859390) error (chunk not found 9290383360) response
2018/01/28 00:28:28 ERROR : Huge/Out.1.noli.me.tangere.1971.BluRay.Remux.1080p.AVC.FLAC1.0-BMF/Out.1.noli.me.tangere.1971.E08.BluRay.Remux.1080p.AVC.FLAC1.0-BMF.mkv: (9332326400/16319859390) error (chunk not found 9332326400) response

[Stopped the service. Waited 20 seconds. Started again.]

2018/01/28 00:30:55 INFO : Starting bandwidth limiter at 8.301MBytes/s
2018/01/28 00:30:55 INFO : Starting HTTP transaction limiter: max 4 transactions/s with burst 1
2018/01/28 00:30:56 INFO : Seeding: Cache DB path: D:\Temp\rclone\Seeding.db
2018/01/28 00:30:56 INFO : Seeding: Cache chunk path: D:\Temp\rclone\Seeding
2018/01/28 00:31:00 INFO : Seeding: Chunk Memory: true
2018/01/28 00:31:00 INFO : Seeding: Chunk Size: 10M
2018/01/28 00:31:00 INFO : Seeding: Chunk Total Size: 30G
2018/01/28 00:31:00 INFO : Seeding: Chunk Clean Interval: 1h0m0s
2018/01/28 00:31:00 INFO : Seeding: Workers: 4
2018/01/28 00:31:00 INFO : Seeding: File Age: 24h0m0s
2018/01/28 00:31:00 INFO : Seeding: Cache Writes: false
2018/01/28 00:31:00 INFO : Seeding:: Modify window is 1ms
2018/01/28 00:31:00 INFO : cache: deleted (0) chunks
2018/01/28 00:31:00 NOTICE: Seeding:: poll-interval is not supported by this remote
2018/01/28 00:31:10 ERROR : mountpoint “X:” didn’t became available on mount - continuing anyway

[Waited a minute and still cannot access the drive. Stopped the service and started again.]

2018/01/28 00:32:10 INFO : Starting bandwidth limiter at 8.301MBytes/s
2018/01/28 00:32:10 INFO : Starting HTTP transaction limiter: max 4 transactions/s with burst 1
2018/01/28 00:32:11 INFO : Seeding: Cache DB path: D:\Temp\rclone\Seeding.db
2018/01/28 00:32:11 INFO : Seeding: Cache chunk path: D:\Temp\rclone\Seeding
2018/01/28 00:32:11 INFO : Seeding: Chunk Memory: true
2018/01/28 00:32:11 INFO : Seeding: Chunk Size: 10M
2018/01/28 00:32:11 INFO : Seeding: Chunk Total Size: 30G
2018/01/28 00:32:11 INFO : Seeding: Chunk Clean Interval: 1h0m0s
2018/01/28 00:32:11 INFO : Seeding: Workers: 4
2018/01/28 00:32:11 INFO : Seeding: File Age: 24h0m0s
2018/01/28 00:32:11 INFO : Seeding: Cache Writes: false
2018/01/28 00:32:11 INFO : Seeding:: Modify window is 1ms
2018/01/28 00:32:11 INFO : cache: deleted (0) chunks
2018/01/28 00:32:11 NOTICE: Seeding:: poll-interval is not supported by this remote
2018/01/28 00:32:21 ERROR : mountpoint “X:” didn’t became available on mount - continuing anyway

[Rebooted the computer. It’s back to normal.]

2018/01/28 00:42:36 INFO : Starting bandwidth limiter at 8.301MBytes/s
2018/01/28 00:42:36 INFO : Starting HTTP transaction limiter: max 4 transactions/s with burst 1
2018/01/28 00:42:38 INFO : Seeding: Cache DB path: D:\Temp\rclone\Seeding.db
2018/01/28 00:42:38 INFO : Seeding: Cache chunk path: D:\Temp\rclone\Seeding
2018/01/28 00:42:38 INFO : Seeding: Chunk Memory: true
2018/01/28 00:42:38 INFO : Seeding: Chunk Size: 10M
2018/01/28 00:42:38 INFO : Seeding: Chunk Total Size: 30G
2018/01/28 00:42:38 INFO : Seeding: Chunk Clean Interval: 1h0m0s
2018/01/28 00:42:38 INFO : Seeding: Workers: 4
2018/01/28 00:42:38 INFO : Seeding: File Age: 24h0m0s
2018/01/28 00:42:38 INFO : Seeding: Cache Writes: false
2018/01/28 00:42:38 INFO : cache: deleted (0) chunks
2018/01/28 00:42:38 INFO : Seeding:: Modify window is 1ms
2018/01/28 00:42:38 NOTICE: Seeding:: poll-interval is not supported by this remote

[After a while, some error happened but I assume they are normal. The drive has been functioning well since the reboot.]

2018/01/28 01:21:49 ERROR : Huge/Out.1.noli.me.tangere.1971.BluRay.Remux.1080p.AVC.FLAC1.0-BMF/Out.1.noli.me.tangere.1971.E08.BluRay.Remux.1080p.AVC.FLAC1.0-BMF.mkv: (9252229120/16319859390) error (chunk not found 9248440320) response
2018/01/28 01:21:49 ERROR : Huge/Out.1.noli.me.tangere.1971.BluRay.Remux.1080p.AVC.FLAC1.0-BMF/Out.1.noli.me.tangere.1971.E08.BluRay.Remux.1080p.AVC.FLAC1.0-BMF.mkv: ReadFileHandle.Read error: low level retry 1/10: EOF
2018/01/28 01:21:55 ERROR : Huge/Out.1.noli.me.tangere.1971.BluRay.Remux.1080p.AVC.FLAC1.0-BMF/Out.1.noli.me.tangere.1971.E08.BluRay.Remux.1080p.AVC.FLAC1.0-BMF.mkv: (9290383360/16319859390) error (chunk not found 9290383360) response


#6

I wonder if it isn’t shutting down properly in some way.

Do you have the logs for the shutdown?


#7

Thank you for your help looking into it. Nothing related to shutting down showed up in the rclone.log from -v. I simply closed the program. The rclone process didn’t show up on Windows Task Manager anymore after the closing. Would you please advise if there is a proper way to shut down rclone mount on Windows?
Should I change to have a detailed log from -vv, instead of just -v?
Thanks!


#8

As in you pressed CTRL-C in the cmd window it was running in, or something else? If you CTRL-C rclone it does a more graceful shutdown - I was wondering if that might be the cause.

However I tried an experiment under Windows 7 of killing rclone with task manager then restarting it - that worked fine.

Probably how you are doing it is fine - I’m not sure how essential the shutdown is. Windows is good at keeping track of its resources normally.

@billziss-gh do you have any ideas as to why rclone might not restart under Windows 10?


#9

Thank you so much for your reply.

In the past three days, I have re-started the mount drive using nssm to start clone as a Windows service. I did it for more than 30 times. I am happy to report that the problem no longer happens!

I suspect it could be a Windows problem happened when different user accounts (normal user vs. administrator) are involved, and when rclone mount was shutting down while other programs were accessing it. (e.g. perhaps rclone mount was started by a normal user, while the program accessing the remote drive was run as administrator.)

Now that I always launch rclone mount as system account, and always launch the programs accessing the remote drive as administrative account, I no longer have the issue.

I still don’t know the exact root cause of the problem I encountered previously, but my suggestion to other users who might encounter such an issue on a Windows in the future is:

  1. Launch rclone mount as a service, using nssm. (This is detailed in another forum post.)
  2. If the above still doesn’t solve the problem, try to make all programs accessing it run by the same account such as the administrator account. Better reboot after the change, in case some old process of a different user account is still running.

Thank you ncw for the great program and patience in answering me!


#10

Glad you got it sorted :smile:

Do you think it is worth writing how to do this up in the rclone wiki?

My pleasure!


#11

Can you link the forum post for using nssm ?
thanks


#12

Guys, unfortunately I just encountered this issue again. I believe it’s more likely a problem of Windows or the Windows emulation of Fuse than a rclone problem. The rate of happening is low when using nssm to start rclone as a system service anyway, as I only encountered it once in the past week, as compared to every day before I used nssm. Once the problem occurs, the only way to solve it is to reboot the computer, which also makes me feel like the root cause could be more related to Windows than rclone.

I changed --vfs-cache-mode from off to writes yesterday. Not sure if it’s related or not. I will change it back to off to see if I ever encounter the issue again.

The log using -vv is like the following, not telling too much though. (Yeah you will see some weird parameters set by me, because I’m using rclone+GD to seed some torrents ;))

2018/02/04 22:10:26 DEBUG : Using config file from “C:\Program Files\rclone\rclone.conf”
2018/02/04 22:10:26 INFO : Starting HTTP transaction limiter: max 4 transactions/s with burst 1
2018/02/04 22:10:26 DEBUG : rclone: Version “v1.39-099-gb3d8b7e2” starting with parameters [“C:\Program Files\rclone\rclone.exe” “mount” “crypt:” “X:” “–config=C:\Program Files\rclone\rclone.conf” “–no-checksum” “–allow-other” “–max-read-ahead=5M” “–dir-cache-time=240h” “–buffer-size=0k” “–cache-chunk-no-memory” “–cache-chunk-size=5M” “–cache-total-chunk-size=50M” “–cache-info-age=24h” “–cache-db-purge” “–cache-dir=T:\rclone\” “–cache-chunk-path=T:\rclone\” “–cache-db-path=T:\rclone\” “–cache-chunk-clean-interval=1m” “–cache-read-retries=30” “–cache-workers=4” “–cache-rps=4” “–tpslimit=4” “–low-level-retries=10” “–retries=10” “–contimeout=2m” “–log-file=T:\rclone\rclone.log” “–no-modtime” “–vfs-cache-mode=writes” “–vfs-cache-max-age=1m” “-vv”]
2018/02/04 22:10:27 DEBUG : CryptCache: wrapped GD:crypt at root
2018/02/04 22:10:27 DEBUG : CryptCache: Purging the DB
2018/02/04 22:10:27 INFO : CryptCache: Cache DB path: T:\rclone\CryptCache.db
2018/02/04 22:10:27 INFO : CryptCache: Cache chunk path: T:\rclone\CryptCache
2018/02/04 22:10:27 INFO : CryptCache: Chunk Memory: false
2018/02/04 22:10:27 INFO : CryptCache: Chunk Size: 10M
2018/02/04 22:10:27 INFO : CryptCache: Chunk Total Size: 50M
2018/02/04 22:10:27 INFO : CryptCache: Chunk Clean Interval: 1m0s
2018/02/04 22:10:27 INFO : CryptCache: Workers: 4
2018/02/04 22:10:27 INFO : CryptCache: File Age: 24h0m0s
2018/02/04 22:10:28 DEBUG : CryptCache: wrapped GD:crypt at root
2018/02/04 22:10:28 DEBUG : CryptCache: Purging the DB
2018/02/04 22:10:28 INFO : CryptCache: Cache DB path: T:\rclone\CryptCache.db
2018/02/04 22:10:28 INFO : CryptCache: Cache chunk path: T:\rclone\CryptCache
2018/02/04 22:10:28 INFO : CryptCache: Chunk Memory: false
2018/02/04 22:10:28 INFO : CryptCache: Chunk Size: 10M
2018/02/04 22:10:28 INFO : CryptCache: Chunk Total Size: 50M
2018/02/04 22:10:28 INFO : CryptCache: Chunk Clean Interval: 1m0s
2018/02/04 22:10:28 INFO : CryptCache: Workers: 4
2018/02/04 22:10:28 INFO : CryptCache: File Age: 24h0m0s
2018/02/04 22:10:28 INFO : Encrypted drive ‘crypt:’: Modify window is 1ms
2018/02/04 22:10:28 DEBUG : Encrypted drive ‘crypt:’: Mounting on “X:”
2018/02/04 22:10:28 NOTICE: Encrypted drive ‘crypt:’: poll-interval is not supported by this remote
2018/02/04 22:10:28 DEBUG : vfs cache root is “T:\rclone\vfs\crypt”
2018/02/04 22:10:28 DEBUG : Encrypted drive ‘crypt:’: Mounting with options: ["-o" “fsname=crypt:” “-o” “subtype=rclone” “-o” “max_readahead=5242880” “-o” “atomic_o_trunc” “-o” “uid=-1” “-o” “gid=-1” “–FileSystemName=rclone” “-o” “allow_other”]
2018/02/04 22:10:28 DEBUG : Encrypted drive ‘crypt:’: Init:
2018/02/04 22:10:28 DEBUG : Encrypted drive ‘crypt:’: >Init:
2018/02/04 22:10:28 DEBUG : /: Statfs:
2018/02/04 22:10:28 DEBUG : /: >Statfs: stat={Bsize:4096 Frsize:4096 Blocks:8796093022207 Bfree:8796093022207 Bavail:8796093022207 Files:1000000000 Ffree:1000000000 Favail:0 Fsid:0 Flag:0 Namemax:255}, errc=0
2018/02/04 22:10:28 DEBUG : /: Getattr: fh=0xFFFFFFFFFFFFFFFF
2018/02/04 22:10:28 DEBUG : /: >Getattr: errc=0
2018/02/04 22:10:38 ERROR : mountpoint “X:” didn’t became available on mount - continuing anyway


#13

Do you think it is worth writing how to do this up in the rclone wiki

I am sorry that it doesn’t completely solved the issue, but at least it makes the problem happen much less.

I do believe it’s worthwhile mentioning that we can use nssm to start rclone as a service on Windows. Instruction of using nssm can be found at: https://nssm.cc/usage.
The forum discussion is at: Installing rclone mount on Windows as service?.
The current instruction on the “rclone mount” page that "It is also possible to start a drive from the SYSTEM account (using the WinFsp.Launcher infrastructure) " doesn’t seem to work for me when I tried WinFsp. Perhaps I simply didn’t configure WinFsp correctly because of lack of instructions, or it might be just be on the roadmap of WinFsp.Launcher infrastructure?

Thank you for all your help! I will continue to try and monitor and report back if I find out more!


#14

I’m not sure what to suggest…

We could ask @billziss-gh (author of WinFSP)

Can you write it up in the rclone wiki for me? I haven’t a clue about it so it would be better if someone who knows what they are taking about did!

That would be a question for Bill also!


#15

Hello ncw,

Sorry for the deferred reply due to work.

Can you write it up in the rclone wiki2 for me? I haven’t a clue about it so it would be better if someone who knows what they are taking about did!

How about something like the following for https://rclone.org/commands/rclone_mount/ :

The easiest way around this is to start the drive from a normal command prompt. It is also possible to start a drive from the SYSTEM account which creates drives accessible for everyone on the system. To start a drive from the SYSTEM account, you can install and configure the program nssm to run it as a Windows service, or possibly using the WinFsp.Launcher infrastructure.


#16

Thanks - have put a note in the docs for the next release.