Mounting Multiple Service - Non flat union

What is the problem you are having with rclone?

What is the best way to mount to multiple (10+) providers. Having each command run in a separate window isn't nice. I thought to use Unions, but it flattens everything at first level. I am wishing to have something like

R:  - new mount point
-Dropbox - Be mounted here
-OneDrive - Be mounted under here
-Drive - G Drive be mounted under here
-DBCrtypt - Encrypted dropbox be mounted under this etc

Edit: It seemd daemon is the answer. I just need to find how to map empty drive now

What is your rclone version (output from rclone version)

rclone v1.55.1
- os/type: windows
- os/arch: amd64
- go/version: go1.16.3
- go/linking: dynamic
- go/tags: cmount

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 64 bit

Which cloud storage system are you using? (eg Google Drive)

Various inlcuding OneDrive, DropBox, Google Drive, pCloud

hello and welcome to the forum,

can be as simple as using one batch file, call it mount.cmd

  1. create the root mount folder.
    in my case B:\rclone\mount.
    i have created a small 1GB volume all my computers as B: drive.
    i also use that with VSS snapshots as per my wiki

  2. create the batch file

start rclone mount Dropbox: B:\rclone\mount\Dropbox
start rclone mount OneDrive: B:\rclone\mount\OneDrive
start rclone mount Drive: B:\rclone\mount\Drive
start rclone mount DBCrtypt : B:\rclone\mount\DBCrtypt

3A. task scheduler to run the batch file at boot or on demand demand.
if you configure it correctly, all the console windows will be hidden.
3B. another way to hide the console windows, add --no-console to the rclone command

  1. to make all these mountpoints appear as single drive letter, instead of B:\rclone\mount
    subst R: b:\mount\rclone
1 Like

Thanks. With joining inputs from various threads, I've come up with a solution. I don't mind having a single window open as it allows easy termination of application. I've come with the following solution

rclone rcd --rc-no-auth
rclone rc mount/mount fs="map" mountPoint="R:"
rclone rc mount/mount fs=db: mountPoint="R:\Dropbox" vfsOpt="{\"CacheMode\": 3}" -o vfs-cache-mode=full -o cache-dir=cache
rclone rc mount/mount fs=drive: mountPoint="R:\Drive" vfsOpt="{\"CacheMode\": 3}" -o vfs-cache-mode=full -o cache-dir=cache
rclone rc mount/mount fs=one: mountPoint="R:\OneDrive" vfsOpt="{\"CacheMode\": 3}" -o vfs-cache-mode=full -o cache-dir=cache
rclone rc mount/mount fs=onecrypt: mountPoint="O:" vfsOpt="{\"CacheMode\": 3}" -o vfs-cache-mode=full -o cache-dir=cache

What I would be doing is mounting the encrypted folder as a drive for encryption. The remaining folders will be mounted inside R: as they would be used rarely.

The missing bit currently, is I can't set a volume name. The below command doesn't set the volume name. I am on Windows 10 - tried with Admin as well as normal user. Any inputs

rclone rc mount/mount fs=one: mountPoint="O:" -o volname=OneDrive vfsOpt="{\"CacheMode\": 3}"

not sure about volume names, as i never use them.

Ok, Cache I introduced just now only, so didn't add all of them with this option in practical. Thanks, I'll make adjustments.

It seems mounting under an already mounted drive by rclone doesn't work. So, I'll continue to use subst instead.

Noticed that I was specifying cache type twice, so I'll get rid of it as well. :slight_smile:

correct, cannot mount under another mount.

keep us posted....

That is true. One trick that does work is to create ram disk mounted as a drive letter, and then rclone mount into subdirectories of that. See #5015. I have not used it more than in a proof-of-concept, so no idea if it is worth it, just mentioning it.

Perhaps this works (untested):

mountOpt="{\"volname\": \"OneDrive\"}"

No, it doesn't.

I thought about it as well, but had dropped it as didn't want to install ramdisk. I see from your post that it is available as part of WinFS Dev Tools (which I did skip). Does it add any value over using subst.

Probably not. Perhaps even the opposite.

i would not trust that ram disk, who knows how stable it really is.
no need to induce any more kernel drivers and whatnot.

on all my computers/servers, i create a small 1GB partition as the b: drive.
a more reliable for rclone mounts.
and odds are ramdisk would not work for VSS snapshots.

Running rclone rc options/get reveals the name is "VolumeName", so the following does work (tested :smile:)

mountOpt="{\"VolumeName\": \"OneDrive\"}"
1 Like

can you please tell what do you mean by root mount folder? did you create hdd 1gb partition?

I guess what is meant is just to create a folder somewhere that can serve as parent for your mounts. Then you mount remotes as subfolders of that. No need for the separate partition, in my opinion.

if just creating a rclone mount, a dedicated partition is not a requirement.

i explain the logic in my wiki
however, creating VSS snapshots and rclone mounts on c:, can get very confusing and lead to all kinds of mistakes from typos or from a script.
i have a python script that coordinates all my backups using VSS, 7zip, fastcopy and of course rclone.
I made such a mistake and paid a heavy price.
for such a mistake, have to make sure it never happens twice.

The most reliable and least confusing solution was to create a tiny partition 1GB in size.

rclone rc mount/mount fs=onecrypt: mountPoint="O:" mountOpt="{\"VolumeName\": \"OneDrive\"}" vfsOpt="{\"CacheMode\": 3}"
Indeed this worked

I stay away from C: entirely. All portable apps go on a separate drive altoger so I can reinstall Windows whenever required without worrying about backing up data.

I will not worry about creating a separate mountpoint. subst is fine. It does report space of the orginal drive, but I'll live with it. Neither RAM disk nor separate mountpoint can get awy with it.

Thanks a lot for your help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.