Mounting Jottacloud Jotta/Sync Mountpoint failes to overwrite files

What is the problem you are having with rclone?

I use jottacloud and want to mount a subfolder in the Jotta/Sync mountpoint on windows10.
Mounting works flawlessly and I can browse the files, open the files and even create new files (sometimes only the file, sometimes also with content).
When it comes to save over an existing file (aka replacing the file with a new one) I get a permission denied error:

"You do not have permission to open this file. See the owner of the file or an administrator to obtain permission."

The file that I tired to overwrite in the logs is called test.txt.

Here are the permissions of the test.txt file: one system account with read/write and the "Everyone" with just read and special permissions.

Btw, I also tried to mount to a subfolder instead of a whole new drive and the same issue exists.

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.0-beta.6264.7a909ebfb
- os/version: Microsoft Windows 10 Pro 21H2 (64 bit)
- os/kernel: 10.0.19044.1766 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.18.3
- go/linking: static
- go/tags: cmount

WinFSP version: winfsp-1.10.22006 (latest as of 21.6.2022)

Which cloud storage system are you using? (eg Google Drive)

Jottacloud official (not white labeled)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone.exe mount --rc --rc-addr localhost:19090 --config "-snip-/rclone.conf" --vfs-cache-mode writes --log-file=C:\\tmp\\rclone.log -vv jotta-personal:LSB Z:

The rclone config contents with secrets removed.

type = jottacloud
configVersion = 1
client_id = jottacli
client_secret = 
tokenURL =
token = {"access_token":"-snip-","expiry":"2022-06-21T10:19:37.7149477+02:00"}
username = -snip-
device = Jotta
mountpoint = Sync

A log from the command with the -vv flag

  • Mounting is supposed to enable write too, right?
  • Is there a command parameter missing?
  • Why is "Everyone" just having read permissions?

Thank you very much in advance!

Start here:

rclone mount

And check out those 3 sections on Windows.

Thanks, Animosity022. I read the whole docs and couldn't find the issue.
There is indeed a section about the permissions on windows but I have no knowledge about the internas how they will be handled, also in regards to winFsp.

Maybe you can help me a bit more?

is there a reason to use the beta version of rclone?

what is a bit strange is that:
your username is not listed.
S-1-0-65534 is listed

Yes asdffdsa, I use the beta of rclone as the latest stable had the same issue and the beta had a jottacloud improvements which I believed will fix the issue.

Thanks for the winfsp link! I'm a AzureAD user (and local admin) which already caused some user-issues over the years as the user account is not a "normal" user to windows.

I guess I will close the issue here and will try to find a fix at winfsp.

Update to all AzureAD users with the same issue:
winFsp just got an update in the beta channel that can handle AzureAD user mappings!

Here is my new permission window and I can use mounting as it should be:

Thank you @asdffdsa for the help :slight_smile:

1 Like


the good news is that this is not a rclone bug.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.