Mounting Gdrive on Synlogy

What is the problem you are having with rclone?

Hey everyone. Rclone seems successfully installed, in SSH i see my Google drive files and directory. the issue is I cannot mount it as a folder in Synlogy. I followed many different guides, but no success.


rclone v1.66.0

  • os/version: unknown
  • os/kernel: 4.4.302+ (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.22.1
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using?

Google Drive

My Rclone.service file:

Description=Rclone Service

ExecStart=/usr/bin/rclone mount gdrive: /volume1/rclone-mount/gdrive
--dir-cache-time 1000h
--log-level INFO
--log-file /volume1/rclone-mount/config/rclone_mount.log
--poll-interval 15s
--umask 000
--cache-dir=/volume1/rclone-mount/rclone-cache \
--vfs-cache-mode full
--vfs-cache-max-size 4G
--vfs-cache-max-age 0m \

ExecStop=/bin/fusermount -uzq /volumel/media


Thank you <3

change --log-level to DEBUG and answer should be in rclone_mount.log

welcome to the forum,

i think the issues are with the systemd service file, not with rclone.

  1. there are trailing spaces. as seen from nano editor

  2. cannot have a traliing slash on the last line of ExecStart
    --vfs-cache-max-age 0m \

Thank you for your prompt aswers.
I've been able to make it work by following this tutorial meanwhile:

In case anyone might need this in the future i will leave here the script i used in scheduled task:

sudo bash /volume1/rclone/config/

and the file

/usr/bin/rclone mount -v gdrive: /volume1/rclone/gdrive/mount --allow-other --dir-cache-time 672h --vfs-cache-max-age 675h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 1G --buffer-size 32M &

thanks again <3

Nevermind my last post.
Now the folder is successfully mounted in Synology, i see the files, but I cannot read them or write.
Any hint?

imho, that mount command is very good, would not use it.

need to use a rclone debug log file, the answer should be there?

Can you assist me in producing the log?

@kapitainsky shared that up above.

and for some reason, you had --log-file /volume1/rclone-mount/config/rclone_mount.log in the systemd file
then removed it from that youtube command.

Why to specify cache parameters when you do not use vfs cache? Default is --vfs-cache-mode off.

Do not use random flags you just found somewhere on Internet. Start with something simple e.g.:

/usr/bin/rclone mount -v gdrive: /volume1/rclone/gdrive/mount --allow-other --dir-cache-time 9999h --vfs-cache-max-age 9999h --vfs-cache-mode full --vfs-cache-max-size 100G --cache-dir=/volume1/rclone-mount/rclone-cache

If not sure which flags to use read docs or ask.

that youtube command is terrible.

fwiw, these flags do not use require the vfs file cache, do not require --vfs-cache-mode
--vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 1G

I used the string you sent me

/usr/bin/rclone mount -v gdrive: /volume1/rclone/gdrive/mount --allow-other --dir-cache-time 9999h --vfs-cache-max-age 9999h --vfs-cache-mode full --vfs-cache-max-size 100G --cache-dir=/volume1/rclone-mount/rclone-cache

but i get the same error when i try to read or write any file.

The error says (translated in english)
cant execute the operation because the netwrok is instable or the system busy, try later

Update: odd: I can download the files mounted in drive from the web interface of synology to my pc. I just cannot copy them anywhere else on the synology or write any file in the gdrive mount from the synology.

please undrestand, we cannot see into your machine and we are just volunteers trying to help you.
help us by doing as we ask, ok?

so we have mentioned this a few times, you need to use a debug log.
the answer should be in the debug log.

Sure, I have no expectations of any kind and am very grateful for the support I am receiving. As you can see, I am following all the instructions I receive, however, I am not able to produce the log. If you assist me on how to do it, I can provide it to you immediately.

we already already did that.
take a few minutes to re-read all the posts in this topic and then take a few minutes to read the docs.

I tried both documentation and the prompt offered me from the other user, but i can't seem to produce a log file or if it is produced i cannot find it

that is not valid, there is no command.

append this to your mount command
--log-level=DEBUG --log-file=mylog-file.txt

1 Like

Like this, correct?

In what path it should produce the log?



SSH to your Synology and run:

/usr/bin/rclone mount -v gdrive: /volume1/rclone/gdrive/mount --allow-other --log-level=DEBUG --log-file=mylog-file.txt

log will be stored in the same directory you run this command from.


/usr/bin/rclone mount gdrive: /volume1/rclone/gdrive/mount --allow-other --log-level=DEBUG --log-file=mylog-file.txt
1 Like

Thank you both for the assistence.
I managed to produce the log file in a folder and then cat namefile.txt
I get this output:

Blockquote 2024/04/11 16:24:11 DEBUG : rclone: Version "v1.66.0" starting with parameters ["/usr/bin/rclone" "mount" "gdrive:" "/volume1/rclone/gdrive/mount" "--allow-other" "--log-level=DEBUG" "--log-file=mylog-file.txt"]
2024/04/11 16:24:11 DEBUG : Creating backend with remote "gdrive:"
2024/04/11 16:24:11 DEBUG : Using config file from "/root/.config/rclone/rclone.conf"
2024/04/11 16:24:12 Fatal error: failed to mount FUSE fs: directory already mounted, use --allow-non-empty to mount anyway: /volume1/rclone/gdrive/mount

I'm googling this error and troubleshooting with what i read on the forum