Mounting cloud folders just sits there and does nothing

What is the problem you are having with rclone?

I had rclone set up great and had no issues running the sync command to upload files to my Google Drive. After restarting my Unraid linux server, the Google Drive locations fail to mount, and running the mount script just sits there and does nothing.

I'm pretty new to this, so I apologize if I left anything out. Please let me know if I can get any other information that would help.

Thank you!

What is your rclone version (output from rclone version)

I believe it's 1.56.0, but am getting this message when attempting to update:

root@MediaVault:~# rclone version
rclone v1.56.0
- os/version: slackware 14.2+ (64 bit)
- os/kernel: 5.10.28-Unraid (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.16.5
- go/linking: static
- go/tags: none
root@MediaVault:~# curl | sudo bash
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  4497  100  4497    0     0   1263      0  0:00:03  0:00:03 --:--:--  1263
   creating: tmp_unzip_dir_for_rclone/rclone-v1.56.1-linux-amd64/
  inflating: tmp_unzip_dir_for_rclone/rclone-v1.56.1-linux-amd64/git-log.txt  [text]
  inflating: tmp_unzip_dir_for_rclone/rclone-v1.56.1-linux-amd64/rclone  [binary]
  inflating: tmp_unzip_dir_for_rclone/rclone-v1.56.1-linux-amd64/README.txt  [text]
  inflating: tmp_unzip_dir_for_rclone/rclone-v1.56.1-linux-amd64/README.html  [text]
  inflating: tmp_unzip_dir_for_rclone/rclone-v1.56.1-linux-amd64/rclone.1  [text]
mandb not found. The rclone man docs will not be installed.

rclone v1.56.1 has successfully installed.

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount Google:RnD/MediaVault_Backup /mnt/disks/Google --allow-non-empty --max-read-ahead 1024k --allow-other
rclone mount encrypt:secure /mnt/disks/encrypt --allow-non-empty --max-read-ahead 1024k --allow-other

The rclone config contents with secrets removed.

type = drive
client_id = 
client_secret = 
scope = drive
token = {"access_token":
team_drive = 

type = crypt
remote = Google:secure
password = 
password2 = 

A log from the command with the -vv flag

root@MediaVault:~# rclone mount Google:RnD/MediaVault_Backup /mnt/disks/Google --allow-non-empty --max-read-ahead 1024k --allow-other -vv
2021/09/23 21:02:00 DEBUG : rclone: Version "v1.56.0" starting with parameters ["rcloneorig" "--config" "/boot/config/plugins/rclone/.rclone.conf" "mount" "Google:RnD/MediaVault_Backup" "/mnt/disks/Google" "--allow-non-empty" "--max-read-ahead" "1024k" "--allow-other" "-vv"]
2021/09/23 21:02:00 DEBUG : Creating backend with remote "Google:RnD/MediaVault_Backup"
2021/09/23 21:02:00 DEBUG : Using config file from "/boot/config/plugins/rclone/.rclone.conf"
2021/09/23 21:02:06 DEBUG : Google drive root 'RnD/MediaVault_Backup': 'root_folder_id = 0AEH0RNPuFY1IUk9PVA' - save this in the config to speed up startup
2021/09/23 21:02:06 DEBUG : Google drive root 'RnD/MediaVault_Backup': Mounting on "/mnt/disks/Google"
2021/09/23 21:02:06 DEBUG : : Root:
2021/09/23 21:02:06 DEBUG : : >Root: node=/, err=<nil>
2021/09/23 21:02:15 DEBUG : /: Attr:
2021/09/23 21:02:15 DEBUG : /: >Attr: attr=valid=1s ino=0 size=0 mode=drwxrwxrwx, err=<nil>
2021/09/23 21:02:31 DEBUG : /: Attr:
2021/09/23 21:02:31 DEBUG : /: >Attr: attr=valid=1s ino=0 size=0 mode=drwxrwxrwx, err=<nil>
2021/09/23 21:02:47 DEBUG : /: Attr:
2021/09/23 21:02:47 DEBUG : /: >Attr: attr=valid=1s ino=0 size=0 mode=drwxrwxrwx, err=<nil>

Hi, welcome to the forum!

It does not do nothing - it serves you the (first) mount! :slight_smile:
This is the way a basic rclone mount command works, there have been some confusion on this for newcomers.

On linux you can use the --daemon option. Note that you need to upgrade to v1.56.1 for this to work. Its usually best to first try your command interactively, like you did, one command at a time, to see that it works as intended. Then go to the next step and make them run in background, or even on schedule, startup or however you want. For troubleshooting then, you need to send the log somewhere, e.g. --log-file or --syslog.

Ahhh ok thank you for the clarification. I'm using Krusader as a file manager in a docker container, so I restarted the container and it seems to be working now. Thank you again!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.