Mount working perfectly but Plex cant read data in folder

Hi. I'm trying to mount my google drive on my server and add that folder to Plex library.
So i made remote and cache in rclone and mounted cache with below command:

sudo rclone mount -v --read-only --allow-other --gid 33 --umask 0027 --dir-cache-time 300h --poll-interval 5m cache: ./plexdrive

Folder is mounting fine and i can see and use all of my Gdrive data on vnc.

The problem is when i try add that mounted folder to plex. plex simply cant see any data on that folder.

tried different things but none of them worked. and i'm not a linux savvy man, maybe missing a simple thing. any help would be appreciated.

In the mounted folder, can you share the output of one location from the command prompt?

felix@gemini:/gmedia$ ls -al
total 21
drwxrwxr-x   1 felix felix    0 Sep 30 13:43 .
drwxr-xr-x  30 root  root  4096 Sep 30 10:33 ..
-rw-rw-r--   1 felix felix  243 May 19 17:33 mounted
drwxrwxr-x  27 felix felix 4096 Oct  1 05:11 Movies
drwxrwxr-x.  7 felix felix 4096 Sep 30 13:43 NZB
drwxrwsr-x.  5 felix felix 4096 Sep 29 07:09 torrents
drwxrwxr-x  22 felix felix 4096 Oct  1 02:12 TV

You probably want to change the umask to 000 instead of what you have. That will open up permissions. Normally, I run my rclone mount as my user rather than root. Doesn't really matter too much unless you are super security concerned. No one uses my Linux box but me so is not really that big an issue.

Here is output of ls -al in mounted directory:

and the output of parent directory:

drwxr-xr-x 6 appbox appbox   11 Oct  1 08:59 'Folder1'
drwxr-xr-x 2 appbox appbox    2 Sep 29 13:40 'Folder2'
drwxr-xr-x 5 appbox appbox    5 Oct  1 08:59  .
drwxr-xr-x 7 root   root      7 Sep 28 17:32  ..
drwxrwxrwx 1 appbox www-data  0 Oct  1 10:45  plexdrive

Also used umask 000 to mount, but Plex still can`t read the directory.

rclone mount -v --read-only --allow-other --gid 33 --umask 000 --dir-cache-time 300h --poll-interval 5m cache: ./plexdrive

And also this time used the mount command without sudo to mount as current user named "appbox". folder mounts successfully, but still Plex cant read the directory.

My mounted folder name is "plexdrive" and here is permission tab in vcn:

And a little lock icon now showing in "plexdrive" directory. not sure whats that means.

The umask 000 opens it up so everything can read the files in there.

Are you running Plex in a docker or another config? The plex user can definitely read those files:


The 3rd rw in there is what says anyone can read the files.

You can also switch over to the plex user assuming you have root there and check it out as that user.

What files are you expecting in there?

I'm not sure there is a Plex user at all, i using a Seedbox and my provider installed Plex by default and i trying to implement Google drive integration with Plex myself.

What files are you expecting in there?

Some rare movies and personal videos that uploaded to my Google drive before.

You can check by running a ps command and see what user plex is running as:

felix@gemini:~$ ps -ef | grep plex
felix    10018  6917  0 07:45 pts/1    00:00:00 grep --color=auto plex
plex     17197 32555  5 05:56 ?        00:05:50 Plex Plug-in [] /usr/lib/plexmediaserver/Resources/Plug-ins-982421575/Framework.bundle/Contents/Resources/Versions/2/Python/ --server-version /usr/lib/plexmediaserver/Resources/Plug-ins-982421575/PlexMovie.bundle
plex     17342 32555  0 05:57 ?        00:00:31 Plex Plug-in [com.plexapp.agents.localmedia] /usr/lib/plexmediaserver/Resources/Plug-ins-982421575/Framework.bundle/Contents/Resources/Versions/2/Python/ --server-version /usr/lib/plexmediaserver/Resources/Plug-ins-982421575/LocalMedia.bundle
plex     32323 32555  0 Sep30 ?        00:01:22 Plex EAE Service
plex     32539     1  0 Sep30 ?        00:00:00 /bin/sh -c  PLEX_MEDIA_SERVER_INFO_VENDOR="$(grep ^NAME= /etc/os-release | awk -F= "{print \$2}" | tr -d \" )"  PLEX_MEDIA_SERVER_INFO_DEVICE="PC"  PLEX_MEDIA_SERVER_INFO_MODEL="$(uname -m)"  PLEX_MEDIA_SERVER_INFO_PLATFORM_VERSION="$(grep ^VERSION= /etc/os-release | awk -F= "{print \$2}" | tr -d \" )"  LD_LIBRARY_PATH=/usr/lib/plexmediaserver/lib  "/usr/lib/plexmediaserver/Plex Media Server"
plex     32555 32539  5 Sep30 ?        00:34:39 /usr/lib/plexmediaserver/Plex Media Server
plex     32599 32555  1 Sep30 ?        00:07:51 Plex Plug-in [com.plexapp.system] /usr/lib/plexmediaserver/Resources/Plug-ins-982421575/Framework.bundle/Contents/Resources/Versions/2/Python/ --server-version /usr/lib/plexmediaserver/Resources/Plug-ins-982421575/System.bundle
plex     32645 32555  0 Sep30 ?        00:00:11 /usr/lib/plexmediaserver/Plex Tuner Service /usr/lib/plexmediaserver/Resources/Tuner/Private /usr/lib/plexmediaserver/Resources/Tuner/Shared 32600 /waitmutex
plex     32677 32555  5 Sep30 ?        00:34:33 Plex Plug-in [com.plexapp.plugins.trakttv] /usr/lib/plexmediaserver/Resources/Plug-ins-982421575/Framework.bundle/Contents/Resources/Versions/2/Python/ --server-version /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Trakttv.bundle

You want to login to that user and just check from the command line if the files are accessible.

Something with ffprobe or mediainfo would be fine.

felix@gemini:/gmedia/Movies/Unsane (2018)$
felix@gemini:/gmedia/Movies/Unsane (2018)$ ls -al
total 25330478
-rw-rw-r-- 1 felix felix 25938409160 Jun 21  2018 'Unsane (2018).mkv'
felix@gemini:/gmedia/Movies/Unsane (2018)$ mediainfo Unsane\ \(2018\).mkv
Unique ID                                : 31493629323965439396648643536880216598 (0x17B173CEFEC3BA1E53E17C6DC1A92A16)
Complete name                            : Unsane (2018).mkv
Format                                   : Matroska
Format version                           : Version 4 / Version 2
File size                                : 24.2 GiB
Duration                                 : 1 h 38 min
Overall bit rate                         : 35.2 Mb/s
Encoded date                             : UTC 2018-06-21 10:22:42
Writing application                      : mkvmerge v24.0.0 ('Beyond The Pale') 64-bit
Writing library                          : libebml v1.3.6 + libmatroska v1.4.9

and it should produce quite a bit of output.

Here is the ps output, seems plex is running as 'appbox' user.

appbox@vnc:~$ ps -ef | grep plex
appbox     10785   10778  0 12:00 pts/1    00:00:00 rclone mount -v --read-only --allow-other --gid 33 --default-permissions --dir-cache-time 300h --poll-interval 5m cache: ./plexdrive
appbox     10820   10746  0 12:01 pts/0    00:00:00 grep plex

And for a good measure i also cant see files inside that directory with rutorrent filemanager.

But i can see all files in VNC with 'appbox' user, that weird. :persevere:

Plex is not running based on the output you shared. Is it running on the same box ? A different box? Are you running a docker with plex or something?

Yes, I asked them and they use docker, so is that possible to mount and add directories to plex in this situation?

You'd have to work with the support team as you have to do some mapping to expose paths and such as I don't use dockers as I find they add a bit of complexity that I don't need.

Perhaps someone else can chime in that is more docker savvy but I'm sure the problem would lie within how the docker is being used and presenting the proper mappings.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.