Mount @ Windows 10 - Solving speed issues with big multimedia files


#1

When using explorer in Windows 10 (but not N version) to access a directory mounted with rclone, if there are multimedia files delays are to be expected, specially if files are big.
This is due to explorer working to show thumbnails and also length, date and other metadata. No solution can be achived hidding the metadata columns.

Thumbnails issue can be solved configuring the options of explorer (show icons not thumbnails). Solving the other issue needs touching the registry.

Note that it is not a windows bug, it is a feature that loads the system; it can be noticed when using local files but behaves badly when files are big and not local, as many times this requires reading most of the file… or at least a big part of it. And if there are many files in a folder, this multiplies the issue.

EASY alternatives: use CMD, speedcommander (not free, 60 days full trial free) or nightcommander (free open source) instead of explorer.

Otherwise, “adjust” windows explorer behaviour:

a) Icons no thumbnails
+
b) Handlers (requires touching the registry)

SETUP for Windows 10 (all but N version):
You will lose duration and date information in the explorer view:
Registry changes (only if you know what you do):

Icons:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
“IconsOnly”=dword:00000001

Handlers

Modify HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\PropertySystem\PropertyHandlers.mp4
to
{#f81b1b56-7613-4ee4-bc05-1fab5de5c07e}

Modify

In
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\PropertySystem\SystemPropertyHandlers

change .mp4 key value to {#f81b1b56-7613-4ee4-bc05-1fab5de5c07e}
(this requires to take ownership of SystemPropertyHandlers)

(EXAMPLE FOR .mp4 files. For other files, proceed the same for the extensions of the files, adding a # in front of the key contents)

Reboot, and ready!

To revert
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
“IconsOnly”=dword:00000000

Remove # in
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\PropertySystem\PropertyHandlers.mp4
{#f81b1b56-7613-4ee4-bc05-1fab5de5c07e}

and in

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\PropertySystem\SystemPropertyHandlers
.mp4 key value {#f81b1b56-7613-4ee4-bc05-1fab5de5c07e}
(needs also reboot)

Enjoy :grinning:
CT

For W7 and W8
see https://social.technet.microsoft.com/Forums/lync/en-US/2cdf4911-99f7-4c2d-b499-fbbeccc9433c/disable-ts-file-content-scanning-for-properties-reloaded-for-win-8-1-solution?forum=w7itproperf

For taking ownership

right click on SystemPropertyHandlers >> Permissions, click on Advanced, at the top it will say: Owner: Trusted installer [change], click change. type:

Administrators

in to the blank box and click Ok, click ok to return to the permissions dialog. Select Administrators and make sure that ‘Full Control’ is checked. Click Ok to return to regedit.

Additional tip
If you wish to change windows property handlers by others, it is possible. see
https://forum.dbpoweramp.com/showthread.php?38116-Replacing-Windows-10-(or-newer)-system-codec-property-handlers-with-dBpoweramp-s

Rebooting
Still trying a way to avoid rebooting. Next idea is killing&restarting explorer and see if no reboot is needed…

source
Most of the black magics comes from knowledge shared by https://social.technet.microsoft.com/profile/daniel%20martín/?ws=usercard-mini


RClone GUI suggestions needed