Mount stopping silently

Hi, I've been having a problem for some days now. I had rclone setup and running, was able to add folders to Plex. I rebooted server for another problem and haven't been able to keep Google Drive mounted now. It appears to fail silently. I was issuing mount with VFS options before, now is just a bare mount with no flags other than allow-other and allow-non-empty

Here is debug log: https://pastebin.com/SWvJ4ekF

Here is conf: https://pastebin.com/mAjAdZPi

allow-non-empty should not be used as it allows for overmounting things/hiding things. Not your problem but I would definitely remove it.

How are you starting rclone? The log shows it finished gracefully meaning something stopped it.

Currently I am just issuing 'rclone mount --allow-other --allow-non-empty gdrive: ~/mnt/gdrive and I cannot for the life of me find what is stopping it nor can my provider though they thought it was FS corruption with Google Drive.

I will omit non-empty in the future, thanks for that.

Hmm...

I also see quite a lot of starting and finishing in the log which looks like rclone is kicked off multiple times somewhere - can you check for that @nukey ?

Actually I think @Animosity022 was right all a long, if you didn't have --allow-non-empty you'd have a sensible error message in the log.

Here is the new log: https://pastebin.com/7CcnF7pA

As to lots of starting and stopping, that's likely when I would restart after it would stop. What happens is that I issue the mount command, am returned to terminal prompt with a PID. I can enter the mount, I can ls. I then will go into Plex to see if I can add a folder, the mount is missing.

I may have fixed this. I removed --allow-non-empty and --contimeout=15s from the service file. I never requested the contimeout flag, so unless that's a default when you mount I have no clue how that ended up there. I'm still unclear what, exactly, was stopping the service however.

--contimeout should have made ERRORs in the log which I didn't see, but you don't need to change the default so removing it is the right choice.

What does your service file look like? Here is the one I use to serve beta.rclone.org (don't copy the options for this - it is a very specialized mount!).

[Unit]
Description=rclone mount
Documentation=http://rclone.org/docs/
After=network-online.target

[Service]
Type=notify
User=www-data
Group=www-data
ExecStart=/usr/bin/rclone mount -v --read-only --config /home/www-data/.rclone.conf --cache-dir /home/www-data/.cache/rclone --dir-cache-time 1m --vfs-cache-mode full --vfs-cache-max-age 168h --allow-non-empty --allow-other --use-mmap=true --vfs-cache-max-size 30G --rc memstore:beta-rclone-org /mnt/beta.rclone.org
ExecStop=/bin/fusermount -uz /mnt/beta.rclone.org
Restart=on-failure
RestartSec=5

[Install]
WantedBy=multi-user.target

It's the barest of the bare now.

[Unit]
Description=rclonemount
After=network.target

[Service]
Type=simple
User=%I
Group=%I
ExecStart=/usr/sbin/rclone mount /home/%I/cloud --allow-other --dir-cache-time 10m --max-read-ahead 9G --checkers 32
ExecStop=/bin/fusermount -u /home/%I/cloud
Restart=on-failure
RestartSec=30
StartLimitInterval=60s
StartLimitBurst=3

[Install]
WantedBy=multi-user.target

That service file is after i removed --allow-non-empty and --contimeout=15s

It's working now and I'm not sure why. Thing is, when it was failing I didn't issue anything but the mount request I posted earlier. Which worked. And the service file was identical to what it is now only it still had the flags I removed.

Hmm... I have a feeling it is all to do with --allow-non-empty and concurrent invocations of rclone mount but I don't know exactly why!

checkesr and max-read-ahead don't do anything on a mount.

If systemd is respawning it for some reason, it would continue to mount over things with non-empty as that allows it rather than just error out.

If it is systemd though, you should see that in the logs.

You can check with a systemctl command:

[felix@gemini ~]$ systemctl status gmedia-rclone
● gmedia-rclone.service - RClone Service
   Loaded: loaded (/etc/systemd/system/gmedia-rclone.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2019-06-26 09:54:16 EDT; 1 day 21h ago
 Main PID: 782 (rclone)
    Tasks: 23 (limit: 4915)
   Memory: 1.8G
   CGroup: /system.slice/gmedia-rclone.service
           └─782 /usr/bin/rclone mount gcrypt: /GD --allow-other --buffer-size 1G --dir-cache-time 96h --log-level INFO --log-file /op>