Mount on ubuntu generates parse error

What is the problem you are having with rclone?

Trying to use fstab on linux. Run in error:

root@pve:/mnt/pve# mount -v onedrive-backup/
2022/06/20 17:10:38 Failed to parse command line: option name can't start with - or _

but as daemon this runs:
root@pve:/mnt/pve# rclone mount onedrive-backup:pve-backup /mnt/pve/onedrive-backup/ --vfs-cache-mode=writes --daemon

Run the command 'rclone version' and share the full output of the command.

rclone v1.58.1

  • os/version: debian 11.3 (64 bit)
  • os/kernel: 5.15.35-2-pve (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.17.9
  • go/linking: static
  • go/tags: none
    root@pve:/mnt/pve#

Which cloud storage system are you using? (eg Google Drive)

Microsoft Onedrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

root@pve:/mnt/pve# mount onedrive-backup/
2022/06/20 17:10:38 Failed to parse command line: option name can't start with `-` or `_`

The rclone config contents with secrets removed.

This is fstab-line:
onedrive-backup:pve-backup /mnt/pve/onedrive-backup  rclone rw,noauto,nofail,_netdev,x-systemd.automount,args2env,vfs_cache_mode=writes,config=/root/.config/rclone/rclone.conf,cache_dir=/var/cache/rclone 0 0

A log from the command with the -vv flag

Paste  log here

Hi Herm,

I am usually on Windows, so this may be very naive, but have you tried an fstab-line without - in the remote and folder names? (That is something like: onedrivetest:pvetest /mnt/pve/test rclone rw,...)

This is the problem. Either remove it or use the latest beta where the problem is fixed!