Mount Not Showing or Syncing Any Files

What is the problem you are having with rclone?

When mounting a remote Google Drive, no files are being shown and files created in the directory are not uploaded to Google Drive.

Output of rclone ls media-crypt:/ showing that a test file exists:

0 test

With drive mounted to /mnt/gdrive-media-cloud (running ls /mnt/gdrive-media-cloud):

[Empty output, no files in directory]

Therefore, the test file is not being shown with the drive mounted.

Although I have used rclone extensively in the past for other purposes, for this project, I have followed this tutorial from Muffin's Lab. I have followed the documentation for all the options being used in the mount command, and to the best of my knowledge, I do not believe this is a configuration error.

Run the command 'rclone version' and share the full output of the command.

rclone v1.57.0
- os/version: ubuntu 21.04 (64 bit)
- os/kernel: 5.11.0-46-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.17.2
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive (drive) and Crypt with crypt mounted, Google Drive as the crypt backend.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

/usr/bin/rclone mount \
  --config=/home/jeff/.config/rclone/rclone.conf \
  --log-level=INFO \
  --log-file=/mnt/4TB/gdrive-media-logs/rclone-mount.log \
  --user-agent=jeffsdrive \
  --umask=002 \
  --gid=1002 \
  --uid=1000 \
  --allow-other \
  --timeout=1h \
  --poll-interval=15s \
  --dir-cache-time=1000h \
  --cache-dir=/mnt/4TB/gdrive-media-cache \
  --vfs-cache-mode=full \
  --vfs-cache-max-size=250G \
  --vfs-cache-max-age=12h \
  media-crypt /mnt/gdrive-media-cloud

The rclone config contents with secrets removed.

type = drive
client_id = [REDACTED]
client_secret = [REDACTED]
scope = drive
root_folder_id = [REDACTED]
token = {"access_token":"[REDACTED]","token_type":"Bearer","refresh_token":"[REDACTED]","expiry":"[REDACTED]"}
team_drive =

type = crypt
remote = media:/
password = [REDACTED]
password2 = [REDACTED]

A log from the command with the -vv flag

2022/01/17 21:25:51 DEBUG : rclone: Version "v1.57.0" starting with parameters ["/usr/bin/rclone" "mount" "-vv" "--config=/home/jeff/.config/rclone/rclone.conf" "--user-agent=jeffsdrive" "--umask=002" "--gid=1002" "--uid=1000" "--allow-other" "--timeout=1h" "--poll-interval=15s" "--dir-cache-time=1000h" "--cache-dir=/mnt/4TB/gdrive-media-cache" "--vfs-cache-mode=full" "--vfs-cache-max-size=250G" "--vfs-cache-max-age=12h" "media-crypt" "/mnt/gdrive-media-cloud"]
2022/01/17 21:25:51 DEBUG : Creating backend with remote "media-crypt"
2022/01/17 21:25:51 DEBUG : Using config file from "/home/jeff/.config/rclone/rclone.conf"
2022/01/17 21:25:51 DEBUG : fs cache: renaming cache item "media-crypt" to be canonical "/mnt/media-crypt"
2022/01/17 21:25:51 INFO  : Local file system at /mnt/media-crypt: poll-interval is not supported by this remote
2022/01/17 21:25:51 DEBUG : vfs cache: root is "/mnt/4TB/gdrive-media-cache"
2022/01/17 21:25:51 DEBUG : vfs cache: data root is "/mnt/4TB/gdrive-media-cache/vfs/local/mnt/media-crypt"
2022/01/17 21:25:51 DEBUG : vfs cache: metadata root is "/mnt/4TB/gdrive-media-cache/vfsMeta/local/mnt/media-crypt"
2022/01/17 21:25:51 DEBUG : Creating backend with remote "/mnt/4TB/gdrive-media-cache/vfs/local//mnt/media-crypt"
2022/01/17 21:25:51 DEBUG : Creating backend with remote "/mnt/4TB/gdrive-media-cache/vfsMeta/local//mnt/media-crypt"
2022/01/17 21:25:51 DEBUG : Local file system at /mnt/media-crypt: Mounting on "/mnt/gdrive-media-cloud"
2022/01/17 21:25:51 INFO  : vfs cache: cleaned: objects 0 (was 0) in use 0, to upload 0, uploading 0, total size 0 (was 0)
2022/01/17 21:25:51 DEBUG : : Root:
2022/01/17 21:25:51 DEBUG : : >Root: node=/, err=<nil>

Thank you in advance to any of willing to take a look into this and lend a hand, I truly appreciate it.

hello and welcome to the forum,

rclone remotes need a colon character, else rclone thinks you intended a local directory

try media-crypt: /mnt/gdrive-media-cloud

1 Like

That did the trick, while I knew that, it somehow just got overlooked. I appreciate it!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.