Mount net/http: timeout awaiting response headers

What is the problem you are having with rclone?

When I do a media scan in Plex it fails on specific tv show every time.

What is your rclone version (output from rclone version)

rclone v1.52.2
os/arch: linux/amd64
go version: go1.14.4

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu Server 20.04, 64bit

Which cloud storage system are you using? (eg Google Drive)

Google (team) Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

My rclone-vfs.service file looks like this:

Description=RClone VFS Service


ExecStart=/usr/bin/rclone mount decrypted: /storage/endpoints/media-remote \
  --allow-other \
  --user-agent='Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.92 Safari/537.36' \
  --config /home/pixel/.rclone.conf \
  --use-mmap \
  --dir-cache-time 120h \
  --timeout 1s \
  --umask 002 \
  --poll-interval=1h \
  --vfs-cache-mode writes \
  --vfs-read-chunk-size 48M \
  --vfs-read-chunk-size-limit 64M \
  --tpslimit 10 \
  --tpslimit-burst 20 \
  --log-level DEBUG \
  --log-file /home/user/logs/rclone.log
ExecStop=/usr/bin/fusermount -uz /storage/endpoints/media-remote


The rclone config contents with secrets removed.

type = drive
client_id = ***
client_secret = ***
scope = drive
token = ***
team_drive = ***

type = drive
client_id = ***
client_secret = ***
scope = drive
token = ***

type = drive
scope = drive
service_account_file = /home/user/***.json
team_drive = ***

A log from the command with the -vv flag

Too lage to post here, so here it is:

Also some background info: I recently made a transition from encrypted to non-encrypted media. I transferred all media from Google Drive to a Google Team Drive. So my Google Team Drive is currently decrypted and mounted. That's why I have a decrypted and encrypted remote configured. I just leave the encrypted remote in case I need to use it for something else.

I also discovered some tv shows didn't have season folders. So I ran this command to move tv show episodes to their specific season folder. Family Guy is one of those tv shows. I've read something about chunk size being a problem, but I'm not sure how to translate that to a solution.

That is odd - it looks like is having trouble retreiving info about that file.

It is just that one file?

Did you try looking at it in the web interface? Can you see it/download it there?

That file being S01E05 right? I just tried it, and it's there and I can download & play it just fine.

It is not only this file. It's also other files from this show. Here is another scan for Family Guy

There was some noise because someone was streaming, but I tried to remove that.

I think the next step could be to move the season folders that have not been scanned by Plex yet and see if a new scan goes well or not.

I moved the 'bad' seasons to a location outside Plex scanning territory through rclone. However since I have --dir-cache-time 120h the mount still shows the old structure. Is it possible for me to refresh only a specific folder? I prefer not to rebuild the entire cache because that takes a lot of time the first time I did it. I also don't have rc running.

Change the poll interval back to something small like 1m, 15 seconds and it'll refresh.

Thanks. Everything seems to run smoothly now. So I'm sure it's only these bad seasons. I'll be moving them back season by season and just rescan the series library to see which episodes are the culprit.

Thanks for your help guys!

1 Like

I still seem to have problems with completely random files. Here is a new log: How could I debug this?

hi, yes
"Otherwise pass directories in as dir=path. Any parameter key starting with dir will refresh that directory, eg"

EDIT: just noticed, i see that you are not use rc

Does it make a difference I mount a team drive instead of my own drive?

I increased the timeout from 1s to 10s, and so far it scanned thousands of files without errors. When I 100% confirmed this to work I'll reply here again.

So changing the timeout to 10s did the trick. I've let multiple programs like Plex, Radarr and Sonarr do their thing, and it all works out great so far.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.