Mount local folder Windows 10

What is the problem you are having with rclone?

A little backstory, I have a free edu team drive which hosts my Plex media. I've had on/off issues with it for the last year. The latest issue, all my files "have exceeded their download quota" even though they haven't. Been like this for over a week. I think google may be cracking down. Anyways, I now have a 14TB HDD to host my files myself. I can not download the files from my gdrive (encrypted) through rclone because of the download limit error. However, if I go to gdrive through chrome I see all the encrypted files. I can not download the files individually, but if I take the root folder google zips it and lets me download. But it is all encrypted. How can I get rclone to decrypt them? I tried mounting a local folder with the encryption. Rclone doesn't see the files originally there, but if I add random test files to the mounted rclone local folder, those files are seen in both the mounted location, and actual local location - but encrypted.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 64bit

Which cloud storage system are you using? (eg Google Drive)

Google Drive - encrypted

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount local-crypt: X:

The rclone config contents with secrets removed.

type = local
nounc = true

type = crypt
remote = local:\Users\XXXX\Downloads\rclone\local
filename_encryption = standard
directory_name_encryption = true
password = 
password2 = 

If these have exactly the same settings (bar remote) as your original config, then it should work

Note that this can just be

remote = C:\Users\XXXX\Downloads\rclone\local

they were copy pasted from the config and i just removed personal details. Ill updated rclone to the newest version and re-test again tonight.

1 Like

Ok, so I updated to 1.55
I simplified the code by deleting the [local] drive in the config, and changing the remote in [local-crypt] to
F:\Users\XXXX\Downloads\rclone\local like you mentioned.

I then run rclone mount local-crypt: x:
and then open up X: and "F:\Users\XXXX\Downloads\rclone\local" side by side. In theory they should be the same folder, one through the windows environment and the other through rclone.
So whatever files were in F:... were not visible in X:. When I added a file into X: I could see the file in X: and the encrypted equivalent in F:.... so I know the mount is working.

What I want need to do is download the encrypted files from gdrive and then find a way to make rclone decrypt them. I thought if I put the encrypted file in F:... that they would appear in X: but that doesn't seem to work. Any other ideas on how to decrypt them?

what is the goal, to permanently decrypt the files and then point plex to that set of files?

If you got the config right and didn't change the file names then that should work just fine.

Are the files in a subdirectory or something like that? (They shouldn't be)

The files are not in a sub directory. I've been testing the behavior with just some basic small sized jpegs dragged and dropped into the folder - the behavior is consistent. Ill try to make a video to really demonstrate what is happening tonight.

the goal is to get access to my files. Google has blocked them from me. Ive tried multiple accounts, tried 1 day, 2 days, 1 week later - always the same error: download quota for this file has been exceeded. Im the only one with access to the drive.

However, google allows me to download them through chrome with their zip process. (Go figure). But the files are encrypted through rclone. So my plan was to download them through chrome, and then somehow unencrypt them on my end so I can store them locally. Yes I used Plex, but this migration doesn't have much to do with it as far as I can figure.

Right now my alternative is to compile a list of almost 15TB of media and find everything again and redownload them 1 by 1. I would rather exhaust other avenues before embarking on this.

ok, so this is a one-time process.

i would:

  1. download all the files as .zip
  2. unzip them into a local folder
  3. then we can create a rclone command to decrypt all the files.

well its a one time process but i doubt google will let me download everything as 1 giant zip, I'm sure im going to have to download each movie as its own zip or something.

Any direction on where I can look to make a command for rclone to decrypt the files?

well, you already have a rclone remote local-crypt located at F:\Users\XXXX\Downloads\rclone\local
i would download a few large zip files, and unzip them into F:\Users\XXXX\Downloads\rclone\local
to decrypt them, a command might look like
rclone copy local-crypt: c:\path\to\a\local\folder

each time you download and unzip a .zip file, you can re-run that command.

might be easier for you to use rclone mount with windows explorer view the decrypted files as the x: drive.
and then copy them to c:\path\to\a\local\folder

So i just tested this quick, without the zip files and it won't work because of my original issue with this.
I dragged and dropped 4 files into the windows location that local-crypt: is set to.
I ran rclone ls local-crypt: and it lists nothing.
I then ran rclone mount local-crypt: x: and dropped a file into x:
I now see it in X: decrypted, and see it in the windows directory encrypted along with the other 3 files I added before (unencrypted).
I now run rclone ls local-crypt: and it list the one file I added to X:

Rclone can not see the files that were added through windows for some reason.

i thought the goal was to download the .zip files and decrypt them?
so not sure why you are trying to put file into the crypt?

Sorry, busy day at work. Yes, the goal is to download and decrypt. I was adding jpegs to test. The rclone crypt can not see any original files that were added into the remote location through non-rclone ways. So it can not see any filed to decrypt.

so let's not make this too complex, no point in adding files to the local crypt.

  1. download one or more .zip files.
  2. unzip them info C:\Users\XXXX\Downloads\rclone\local
  3. test if you can see them as decrypted by running this command and then posting the output
    rclone lsd local-crypt: -vv

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.