Mount. Just creating copies of changed file

I’m trying out to mount my Dropbox but it doesn’t work as expected once mounted.

Everytime I change a file, a new copy of the file is appears in the Dropbox folder. The new file contains the changes and the orignal flie remains unchanaged.

When I mount Dropbox the copies of the file get a another name (.goutputstream…).

I also tested to mount GoogleDrive and I basically get the same behavior, but the copies of the file get the same name as the original.

I mount like this:
$ rclone mount DropboxME: /home/lennart/DropboxME --vfs-cache-mode writes -v

When I changed a file I see this log:

2018/09/13 20:22:37 INFO : Data/.goutputstream-MSN7OZ: Copied (new)
2018/09/13 20:22:37 ERROR : Data/En testfil.txt: File.Rename error: move failed: to/conflict/file/…
2018/09/13 20:22:37 ERROR : Data/En testfil.txt: delayed File.Rename error: move failed: to/conflict/file/…

What am I doing wrong?

I think this is probably

Though I’m not sure about the drive thing - that shouldn’t be making duplicates.

How exactly are you changing the files? Can you give me a sequence of steps to try?

I edit the file, add some text, and save. I use text editor XED in my desktop environment.

When I save file Testfile I can see a new cache file is created, named like goutputstream-TWVXPZ. But in the mounted folder I still see the original version of Testfile.

In Google Drive (browser) I see two notifications:

  1. You uploaded an item goutputstream-TWVXPZ
  2. You renamed an item Testfile from goutputstream-TWVXPZ
    And now there are there are two instances of file Testfile.

With Dropbox I think the behavior is basically the same, but Dropbox does not allow two files with the same name and therefore I get the error at rename.

Thanks for explaining that. I think the fix for the issue above will fix your issue too, so if you subscribe to that issue then you’ll get a notification when it is fixed.

I have attempted to fix this here (uploaded in 15-30 mins)

Feedback welcome :slight_smile:

Thank you very much. It works now.
I have tested to change, delete, rename files and create, delete, rename folders in my mounted dropbox. It has worked fine so far, just slower than working with local files. But I have one issue with creating a new file. I’ll post another question about that.

Thanks for testing :slight_smile: I merged this into the latest beta and it will be in v1.44.