Mount google drive on android

What is the problem you are having with rclone?

hi, i am trying to use emby server on android and connect google team drive directly to it. I have seen several guides with the rooted phone but when I mount through the terminal the folder remains empty, could you help me even if I do not know the terminal world well? thank you

What is your rclone version (output from rclone version)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

hello and welcome to the forum,

when you posted, there was a template of questions, please post the answers so we can help you.

the problem that I don't follow very much terminal usage so I summarized my problem in the first part

first, need to root the device and test that it is rooted.

Yes it is root and install the rclone module on magisk

so what is the exact problem?

I followed various guides also on YouTube to mount google drive on android through rclone with the use of the terminal, I arrive at the cloud folder but my files do not appear, I also saw other guides on the site with my same problem but I could not understand how to fix it

so far, you are not sharing any actionable info other then mentioned some unknown youtube video.

as i mentioned before, when you first posted, there was a template of questions that need to be answered.

This is my log

AFAIK the main differences between mount and fusermount are:

  • path to search for mount.FSname helpers (irrelevant for un-mount)
  • non-root mode is supported only by fusermount
  • only fusermount supports libfuse for mounting (also irrelevant)
  • some flag names, e.g. mount -u -l == fusermount -u -z (i.e. -l vs -z for "laze")

Rclone invokes fusermount only to un-mount. When run by root (uid 0) on a Linux/Android kernel, it's functionally equivalent to umount or mount -u. Internally it just makes the umount kernel call.

I think we could add the following fallback in the code: invoke mount -u or umount if the fusermount is absent or failed to run.

In this particular case the user is probably missing a termux package with the above mentioned shared library, or their magisk plugin is missing a correct LD_LIBRARY_PATH, since mount comes from Android core while fusermount comes from termux or alike.
I'm rather thinking of a general case.

1 Like

how should I behave then?

Did you try this workaround: How to solve mount helper error:CANOT LINK EXECUTABLE "fusermount":library "" not found ? · Issue #73 · Magisk-Modules-Repo/com.piyushgarg.rclone · GitHub from the module issue tracker?

The issue may be specific to the magisk module. Vanilla rclone 1.55.0 + fusermount works fine for me.

Sample output (click to expand)

hammerhead:/data/local/tmp/root # ./rclone version
rclone v1.55.0-DEV
- os/type: android
- os/arch: arm
- go/version: go1.13.4
- go/linking: dynamic
- go/tags: none

hammerhead:/data/local/tmp/root # ./rclone mount -vvv drive: /storage/self/drive
2021/04/25 20:33:44 DEBUG : Using config file from "/data/local/tmp/root/rclone.conf"
2021/04/25 20:33:44 DEBUG : rclone: Version "v1.55.0-DEV" starting with parameters ["./rclone" "mount" "-vvv" "drive:" "/storage/self/drive"]
2021/04/25 20:33:44 DEBUG : Creating backend with remote "drive:"
2021/04/25 20:33:44 DEBUG : Google drive root '': root_folder_id = "###" - save this in the config to speed up startup
2021/04/25 20:33:45 DEBUG : Google drive root '': Mounting on "/storage/self/drive"
2021/04/25 20:33:45 DEBUG : : Root:
2021/04/25 20:33:45 DEBUG : : >Root: node=/, err=<nil>
^C2021/04/25 20:33:49 INFO  : Signal received: interrupt
2021/04/25 20:33:49 INFO  : Exiting...

1 Like

thank you very much, I managed to get it working you were really kind to link that link.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.