Mount fails on macOS Mojave

It used to work before, now I have upgraded to mojave, and tried to mount but it fails with

Fatal error: failed to mount FUSE fs: exit status 2

FUSE 3.8.0 in installed and shows in my system preferences.

I am mounting via Rclone Browser

Try updating the version of osxfuse. According to this thread: 3.8.2 should fix the issue

1 Like

Oh yes. Strangely, the 3.8.0 version told me I was up to date and no updates were available when checking from inside it. But I downloaded 3.8.2 manually and it works indeed.


@ncw Would it be possible to check the version of osxfuse too from rclone?

Not a bad idea… I’m not sure how you’d do it though? Any ideas?

Thankyou for the information

My mistake. I thought rclone checked for the presence of osxfuse too so adding a version check shouldn’t have been difficult. On checking the code I saw that the check is present in the upstream fuse library which makes it difficult for us to do much. Probably better to add the version check too in the fuse upstream.

If you wanted to make an issue upstream, then here is the right place:

Updated to Mojave 10.14, updated Fuse to 3.8.2, still getting mounting error and emssage that the version of Fuse is too old for the OS.
Any thoughts?

I just tried mounting on my mac and have no issues.

Mojave 10.14

textere@seraph:~/Downloads/test ps -ef | grep rclone
  501  2830  2787   0  1:24PM ttys000    0:00.41 rclone mount gcrypt: test

I have no trouble installing Fuse, the problem is mounting the drive through the client.
It worked perfectly fine under High Sierra, but since installing Mojave I get an error code that says that Fuse could not mount the drive and that the version of Fuse I am using is too old for the OS.
I am using the latest version of fuse…(I think). Using 3.8.2

I used rclone 1.44 Mojava 10.14 and fuse 3.8.2 as noted in the screenshot. So I’m saying your config should work as it seems to mirror mine so perhaps something else in your config is going on.

I agree… it SHOULD work LOL
it just isn’t.

So you have an underlying issue with the upgrade or something else going on if it’s not working as all those versions you’ve listed are working fine.

Which is why I am here looking for insight…
It’s all good. I’ll get it figured out, just hoped someone would be having a similar issue.
Thanks for trying to help. I appreciate it

I’d try uninstalling and cleaning up fuse completely. There are a number of app cleaner type programs to make sure all the remnants are gone as based on your issue, it seems to be related to that.

Just to confirm, did you reboot the system after upgrading fuse? Also, try downloading & installing it again via their site.