Mount --daemon failing

What is the problem you are having with rclone?

mount --daemon commands failing with
Fatal error: mount not ready

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2
- os/version: debian 11.6 (64 bit)
- os/kernel: 6.0.0-0.deb11.6-amd64 (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.20.2
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount --daemon filesrvr: ~/FileSrvr/

for example. Failing with multiple destinations. Only since "upgrade" to 1.62.2

The rclone config contents with secrets removed.

- type: sftp
- host:
- user: david
- pass: *** ENCRYPTED ***
- md5sum_command: md5sum
- sha1sum_command: sha1sum
- shell_type: unix

Again - this is unchanged for MONTHS, and in use daily.

A log from the command with the -vv flag

2023/03/19 03:58:05 DEBUG : Setting --transfers "6" from environment variable RCLONE_TRANSFERS="6"
2023/03/19 03:58:05 DEBUG : Setting --check-first "true" from environment variable RCLONE_CHECK_FIRST="true"
2023/03/19 03:58:05 DEBUG : rclone: Version "v1.62.2" starting with parameters ["rclone" "--password-command" "REDACTED" "-vv" "mount" "--daemon" "filesrvr:" "/home/david/FileSrvr/"]
2023/03/19 03:58:05 DEBUG : Creating backend with remote "filesrvr:"
2023/03/19 03:58:05 DEBUG : saving configKey to temp file
2023/03/19 03:58:05 DEBUG : attempting to obtain configKey from temp file /tmp/rclone36162320
2023/03/19 03:58:05 DEBUG : using _RCLONE_CONFIG_KEY_FILE for configKey
2023/03/19 03:58:05 DEBUG : Using config file from "/home/david/.config/rclone/rclone.conf"
2023/03/19 03:58:05 DEBUG : s New connection> to "SSH-2.0-OpenSSH_8.4p1 Debian-5+deb11u1"
2023/03/19 03:58:05 DEBUG : s Shell type "unix" from config
2023/03/19 03:58:05 DEBUG : s Relative path resolved to "/home/david"
2023/03/19 03:58:05 DEBUG : s Using root directory "/home/david"
2023/03/19 03:59:05 DEBUG : s Closing 1 unused connections
2023/03/19 03:59:05 DEBUG : Daemon timed out. Terminating daemon pid 14267
2023/03/19 03:59:05 Fatal error: mount not ready

Failing like this on multiple destinations. Only change: weekly run of curl | bash occurred while I was out yesterday morning. When I tried to mount my server for some chores I neglected yesterday... here we are.

oh yes, other operations are proceeding normally. copy, sync, etc.

holy CARP
I just looked at the release notes for 1.62.x
Looks like mount got a damn-near complete rewrite.
should I just go open this as an issue on github?

Don't know if has something to do with fuse3 ? Had same issue with daemon mount . I just updated fusemount to fusemount3 via sudo apt-get install fuse3

Solved my problem :slight_smile:

trying this now
// jeopardy! music plays //
OK that "worked."

rclone - you need to warn the peeps.

I think they did - if you read under releases :wink:

Estimating 0.1% of rclone users read issues on github. there needs to be a warning at install if fuse3 is not on the path

ETA: even better - ask permission, then install fuse3 if permission granted

I feel like a joke should be made here but I'll leave it :slight_smile:

That's generally a bad can of worms to open as I don't want rclone installing anything I'm not doing myself and each distro is unique in how so that's a beast to maintain.

For mounts, you have to install fuse and that's specific to the OS like Linux, Windows, etc. Not every distro is the same as in your case, you are using Debian which that version does come with fuse3 out of the box.

Ubuntu on the later versions all does it by default.

Thanks for letting me know that, I guess it was all a dream that I had this issue, manually installed fuse3 and it cleared the issue for me.

To allay your confusion: I am on bullseye, but I am using a later kernel out of backports for some hardware issues.

Debian is usually a bit behind as they focus on stability. I'd imagine Debian 12 which will release 'soonish' will have fuse3 out of the box.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.