Mount. Cannot open new empty document

I have mounted Dropbox. I cannot open a new empty file to edit it. I do like this:

  1. In file manager, nemo, in a mounted Dropbox folder: Right click->Create new document->Empty document
  2. I name the document NewEmptyDocument. The file is saved OK. (Size is still 0 bytes).
  3. Double click on the file to edit it and I get a error message in my text editor like:
    Could not open the file /path/to/NewEmptyDocument.
    Unexpected error: Error reading from file: Input/output error

What is wrong? Can this be avoided?

However, it works well to first start the text editor, add some text, and “Save as” new_file in the mounted folder Dropbox folder.

What is the corresponding error in the rclone mount log?

Are you using --vfs-cache-mode? I expect you might need --vfs-cache-mode writes

I mount like this:
rclone mount DropboxHOME: /home/lennart/DropxHOME --vfs-cache-mode writes

I don’t think I get any error message from rclone. This is a part of the verbose log:

2018/10/03 20:01:09 DEBUG : : Statfs:
2018/10/03 20:01:09 DEBUG : : >Statfs: stat={Blocks:524288 Bfree:254206 Bavail:254205 Files:1000000000 Ffree:1000000000 Bsize:4096 Namelen:255 Frsize:4096}, err=
2018/10/03 20:01:09 DEBUG : NewEmptyDocument: Attr:
2018/10/03 20:01:09 DEBUG : NewEmptyDocument: >Attr: a=valid=1s ino=0 size=0 mode=-rw-rw-r–, err=
2018/10/03 20:01:09 DEBUG : /: Attr:
2018/10/03 20:01:09 DEBUG : /: >Attr: attr=valid=1s ino=0 size=0 mode=drwxrwxr-x, err=
2018/10/03 20:01:09 DEBUG : NewEmptyDocument: Open: flags=OpenReadOnly
2018/10/03 20:01:09 DEBUG : NewEmptyDocument: Open: flags=O_RDONLY
2018/10/03 20:01:09 DEBUG : NewEmptyDocument: >Open: fd=NewEmptyDocument ®, err=
2018/10/03 20:01:09 DEBUG : NewEmptyDocument: >Open: fh=&{NewEmptyDocument ®}, err=
2018/10/03 20:01:09 DEBUG : &{NewEmptyDocument ®}: Read: len=4096, offset=0
2018/10/03 20:01:09 DEBUG : NewEmptyDocument: ChunkedReader.openRange at 0 length 134217728
2018/10/03 20:01:10 DEBUG : &{NewEmptyDocument ®}: >Read: read=0, err=
2018/10/03 20:01:10 DEBUG : NewEmptyDocument: Attr:
2018/10/03 20:01:10 DEBUG : NewEmptyDocument: >Attr: a=valid=1s ino=0 size=0 mode=-rw-rw-r–, err=
2018/10/03 20:01:10 DEBUG : &{NewEmptyDocument ®}: Flush:
2018/10/03 20:01:10 DEBUG : &{NewEmptyDocument ®}: >Flush: err=
2018/10/03 20:01:10 DEBUG : &{NewEmptyDocument ®}: Release:
2018/10/03 20:01:10 DEBUG : &{NewEmptyDocument ®}: >Release: err=

Can you search for ERROR in the log? I’d be really suprised if there wasn’t a corresponding one somewhere!

I mounted again with -vv and made the procedure again but there is no ERROR in the whole log.

I’m still not able to open an empty file in the mounted folder with text editor xed. This is not a big problem since there other ways to create a text file. However, I made some other findings:

In the mounted folder I can write text into an empty file from terminal with this command:
$ echo “some text” > newempty2

When I open an empty file with xed from terminal I get a slighly different error message.
$ xed NewEmptyDocument3
** (xed:5609): WARNING **: Hit unhandled case 0 (Error reading from file: Input/output error) in parse_error.

When I open an empty file with text editor nano from terminal I’m able to edit the file and save it. But there is an error message when closing nano:
$ nano NewEmptyDocument
NewEmptyDocument: Input/output error

If I create an empty file in another, local, folder it works to then open it with xed. (I expected that, just double checked that this normally works.)

I tried what you wrote with nano and I couldn’t replicate the problem. I couldn’t find xed for ubuntu so I didn’t try that.

This was using

rclone mount --vfs-cache-mode writes -vv dropbox:test /mnt/tmp/

Which version of rclone are you using? Are you using the latest 1.44 ? (rclone version to check)

~ $ rclone version
rclone v1.43-096-ga9fc86f5-fix-2569-mount-move-beta

  • os/arch: linux/amd64
  • go version: go1.11

Can you try with the latest beta please?