Mount Apple M1 MBP to GSuite/Drive - best method in 2024?

What is currently the best method to mount GSuite/Drive on a M1 MacBookPro (I'm running Ventura 13.6.2)

I would normally install programmes via Homebrew, but I anticipated an issue with rclone and mount using this route:

brew install rclone

"NOTE: This version of rclone will not support mount any more (see 5373).

If mounting is wanted on macOS, either install a precompiled binary or enable the relevant option when installing from source."

so instead I chose to install rclone via the standard script installation:

sudo -v ; curl | sudo bash

Was this a mistake?

Should I now install MacFUSE or FUSE-T?

or should I use serve?

(would it be ok to install MacFUSE using brew?)

I searched the forum to try and find the current best solution, but didn't reach a conclusion.

"If mounting is wanted on macOS, either install a precompiled binary or enable the relevant option when installing from source"

I didn't know how to do this? was running the default install script enough?

What is the problem you are having with rclone?

trying to mount GDrive on a M1 Mac

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.2

  • os/version: darwin 13.6.2 (64 bit)
  • os/kernel: 22.6.0 (arm64)
  • os/type: darwin
  • os/arch: arm64 (ARMv8 compatible)
  • go/version: go1.21.6
  • go/linking: dynamic
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive (GSuite)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount gsuite: /Users/me/Mount
rclone mount gsuite: /Users/me/Mount --vfs-cache-mode full -vvv
rclone nfsmount gsuite: /Users/me/Mount -vvv --allow-other

just a couple of commands I tried. I don't have MacFUSE or FUSE-T on my laptop yet. I wanted to ask first before doing this.

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = drive
client_id = XXX
client_secret = XXX
scope = drive
token = XXX
team_drive =


error I saw was:
2024/03/01 07:52:19 Fatal error: failed to mount FUSE fs: mount stopped before calling Init: mount failed: cgofuse: cannot find FUSE

So I guess I need to install FUSE? But which one macFUSE / FUSE-T. Or is there a better method?

my preferred way of mounting remotes on macOS is:

  1. rclone nfsmount - works out of the box
  2. rclone mount with FUSE-T
  3. rclone mount with macFUSE - IMO this should be avoided - too many issues

To use option 1 please use the latest beta:

sudo -v ; curl | sudo bash -s beta

or wait for rclone v1.66 release


rclone nfsmount gsuite: /Users/me/Mount --vfs-cache-mode full --vfs-cache-max-size 10G --vfs-refresh --vfs-fast-fingerprint --volname gsuite 

Adjust vfs-cache-max-size to what you prefer. This is amount of disk space used for cache.

1 Like

thank you for the quick reply kapitainsky.

Can I just run that command and it will install the beta over my current version? (keeping my Gsuite config?)

Are there any disadvantages of using nfsmount vs mount ?


Not that I am aware of any. On plus side it does not require any extra software.

Maybe one:) It is quite new. But I have been using it for few weeks now and it works better for me than rclone mount

1 Like

Thanks. nfsmount seems to work so far on rclone beta.

Disk space is not an issue at the moment - would you recommend 10Gb? Any performance benefits in picking a higher figure?

10G is just an example. More is better here but If you do not specify limit it will "eat" all your free space:) I would try to have cache bigger than biggest files I work with.

Also given that gdrive is polling remote I would add:

--vfs-cache-max-age 9999h --dir-cache-time 9999h

so all together:

rclone nfsmount gsuite: /Users/me/Mount --vfs-cache-mode full --vfs-cache-max-size 10G --vfs-cache-max-age 9999h --dir-cache-time 9999h --vfs-refresh --vfs-fast-fingerprint --volname gsuite  

Let us know how it works for you.

cheers, I will give that I try.

How should I safely halt the nsfmount? I pressed COMMAND-C in Terminal :

^C2024/03/01 08:33:57 ERROR : /Users/me/Mount: Unmounted rclone mount

also can I send that nsfmount to the background somehow in Terminal?

CTRL-C is ok. Or right click on mount and "disconnect"

you can try to run it with --daemon flag or create launchd service.

Or use shortcuts

1 Like

that's great, thanks.

Apple Shortcut looks very useful, will give that a try too.

I'm running it now with --daemon flag, is there a way to stop it on command line? I just hit the eject icon on Finder alongside localhost (assume that worked?), but is there a command I can type?

From cmd - find the process PID and kill it.

Or if you need to control it from other script then use rc interface:

Then you could use mount/unmount rc command

1 Like

Ah yes, found it via htop.

Is hitting the eject button in Finder a safe way to close the connection?

yes - the same as with external disks etc.

really appreciate your help today :+1:

1 Like

Let us know how it works.

Initially it seems to be working ok. I'm mainly just accessing and browsing the files today.

I am moving my data off Gsuite this month (the monthly fee I think is going up on 22nd March 2024 from £13.80/m to £18/m. Used to be £9 ish at one point). I will let you know how that goes with nsfmount.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.