Mount and rtorrent issues

When using rclone mount (latest beta) rtorrent stops workings - all torrents go to paused.

Doesn't have to be the same directory rtorrent is using. If mount/fuse is in use anywhere on the file system it stops working.


1 Like


is this a new problem, that started with the latest beta?
if you run the latest stable version, do you have the same problem?

if you had posted your issue as a question you would have been asked a bunch of basic questions.
i have re-posted them here, perhaps you can help us help you and answer them?

What is the problem you are having with rclone?

What is your rclone version (output from rclone version)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)


I'm not sure - I've never tried this before with rclone.

Just to clarify: Rclone is not in use. It's mounted to a directory that's not being written/read from. If it's mounted rtorrent (under a different user, in a different directory, not at all using the mount) freezes torrents.

sorry, i am not understanding you.
if rclone is not in use, then this is not a rclone problem?

Yes? Because it's mounted to the file system.

It might be a rtorrent problem, but that doesn't change that it's only happening when rclone is mounted.

not sure why you would call this a bug?

you are not providing us with any details.

why are you using a beta of rclone?

please try to provide answers to my questions and we can start to help you.

I'll try to give more information on why this is a bug.

  1. Run rtorrent, watch torrents download.

  2. Mount rclone on a different user, in a different directory, not at all in use by rtorrent or the rtorrent user.

  3. Watch rtorrent pause and close all active torrents.

If it's not a rclone issue it's likely a fuse issue. Still not sure where the problem is. I only know it happens when rclone is mounted.

Hope that helps!

sorry i tried help you, but you are not providing answers to basic questions all forum posters are asked to provide.

perhaps someone else can help you.
good luck

You're right. Because there are no errors in rclone, there are no errors in rtorrent, there are no errors in dmesg.

All I know is once it's mounted and fuse is in use rtorrent grinds to a halt.

The version is v1.50.0-016-g7bf05631-beta btw.

why are you using beta version of rclone?
please test with the latest stable version and let us know what happens?

ffs it was the beta.

good to hear,
to be clear, the problem does not happen when you are using a non-beta version?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.