Mount and don't download anything except the files that I open

I'm trying to mount a large remote and it usually doesn't use a lot of bandwidth until I open one of the files. Even just opening a 10kb text fille will start using my bandwidth before I stop the whole mount, but browsing the file structure doesn't seem to use that much data.

Would it be possible to simply download files when I open them? The remote is a OneDrive with crypt layer. I tried using --vfs-cache-mode off and minimal, but that doesn't seem to be the right option.

This is how rclone mount works but sometimes it can be your software or OS requesting more files than you expect - for example to generate thumbnails for your file explorer etc.

If you want to limit network activity then run your mount with --vfs-cache-mode full flag.

To limit disk space used by cache add --vfs-cache-max-size 1Gi.



I was going to suggest the very same thing.

Give the full option a try that is what I use with OneDrive.

1 Like

Thanks for the suggestions! I have tried it and unfortunately it still sucks up way more data than I think it should, so perhaps it's just an OS thing or I just have an unrealistic standard.

I'm running RClone v1.65.0 on Windows 10, to be clear. Perhaps there's a setting I can change from the OS side to prevent this from happening?

I'll think on it overnight and see if I can recommend an additional setting.

You keep all details secret and ignore original template hence only vague answer is possible and I leave sorting details to yourself.

I was reluctant to provide the full template as a lot of it would expose client's and my personal information due to the nature of the files, since logs couldn't be redacted automatically like configs do so I would have to go over them manually. I've checked the log and nothing seems out of place, it just seem like something is requesting additional files that I don't intend to open to be downloaded. As you've said, it's probably software or the OS requesting more files than needed.

Currently, I'm just trying to figure if there's something that can be done from the OS side to prevent this from happening. You and LeoW's "vague" answer have been helpful so far, really, and I appreciate your help. If this is the most one could get from the provided information, then perhaps this follow up question is more suitable for the Win10 community as I don't think the problem arises from RClone in this case. Once again, thank you for your help and I apologize if I came across as rude or disrespectful, that was never my intention

No you did not. Sorry if you read my response like that.

Simply without all details it is difficult to guess what might be wrong - this is why template was developed:) To help people to provide complete basic info. It is not written in stone - fully understandable when some parts might be sensitive etc. But originally you did not even reveal what OS you are using etc. So it leaves potential answers open for wild speculations instead of focusing on available facts.

Back to your issue - I am 99% sure it is your system/software requesting these reads. I use onedrive too and mount it frequently. Now if e.g. I open folder with many media files in macOS finder it will trigger a lot of reads - as Finder generates thumbnails. But if I open the same folder in terminal all is quiet.

1 Like

Thank you, brilliant solution! It seems that Windows Explorer is the issue, possibly to generate thumbnails just like in your case.

What worked for me was to open the files through CMD as well. Initially I received Access Denied error, but rclone mount onedrive:/ \\cloud\remote --vfs-cache-mode full --file-perms 0777 --dir-perms 0777 solves the problem for me. Now I can open files and it no longer make unnecessary requests.

Thank you!

I do not know Windows but you can try to add --network-mode to your mount command - maybe Windows Explorer leaves network drives in peace:) If not by default I guess you can switch it on/off somewhere.

Try this at see if it helps.

See attached picture:

Is --network-mode not the same as providing a UNC path (e.g. \\cloud\remote) and does it help in macOS?

I don't mind using CMD to browse for now, but hopefully I could change some settings when I use RClone on my Linux workspace.

Just tried the settings, bandwidth is still going up after the initial file is already loaded.

I think yes - it is the same as mounting some SMB or WebDAV share vs connecting external disk directly. --network-mode is Windows only flag.

Myself I use long lasting --vfs-cache-mode full --vfs-cache-max-age 9999h --vfs-cache-max-size 200Gi --dir-cache-time 9999h and after initial reading things are smooth and fast. Long lasting caches (if space allows) are perfect for onedrive as changes on remote are picked up by polling anyway.


Then here is probably your best alternative solution.
Don't use windows file explorer when using this cloud server.

I like/use another file explorer from the MS Store called Owlfiles. It's free.

Essentially, you need to find an alternate explorer that doesn't do anything other than display the files and nothing more.

In this case, file explorer is too robust an application for you to be using in your configuration. A simpler file explorer that doesn't try everything will probably work well for you.

Thanks for the suggestion! I've checked Owlfiles' page out and it has plenty of features that makes an overkill for my usage (at least for now).

Though, I came across the original Windows File Manager at only ~2MB which is much more suitable for me. It is very barebone (I even have to restart the app to refresh the drives) but it's very lightweight and also only requests the files opened. I've tried several other alternative explorers, but they seem to also download additional files. So I guess this will be my main explorer to use with remote mounts and maybe Owlfiles if I need those features in the future

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.