Mount and Access from within Radarr?

What is the problem you are having with rclone?

I am using

rclone mount gmovie: M: --allow-other --allow-non-empty --cache-db-purge --buffer-size 32M --use-mmap --dir-cache-time 72h --drive-chunk-size 16M  --timeout 1h  --vfs-cache-mode minimal --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G &

to Mount my Movies folder but i cant see the drive inside Radarr.

What is your rclone version (output from rclone version)

rclone v1.51.0

  • os/arch: windows/amd64
  • go version: go1.13.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 Pro, 64 Bit

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

see above

The rclone config contents with secrets removed.

type = cache
remote = gdrive:/Filme/
plex_url =
plex_username = 
plex_password = 
chunk_size = 10M
info_age = 1d
chunk_total_size = 10G
plex_token = 

A log from the command with the -vv flag

theres no output in reg. to my problem even if i use -vv


these flags do nothing on windows.

if you want all processes to see the m: drive then run rclone as system user.

is there a specific reason you are using the cache remote?
"we recommend only using the cache backend if you find you can't work without it"

when i stream media i always use a very simple mount
rclone gcrypt: x: --read-only

i tried to use

rclone mount gmovie: m: --read-only

on a cmd with admin rights but it didnt work

how can i run rclone as a system user? i just used the settings i posted above a few weeks ago and it just worked - dont know what i've changed :frowning:

windows creates two set of permissions for mounts and mapped drives.
if you create a rclone mount as a user with admin rights, other programs running as the same user but with standard right cannot see that mount and vice-versa.

to run as system user, use task scheduler.

could u maybe post everything i need to reconstruct what you have done?
all the needed tabs - general, triggers, ...

edit:// running cmd as admin and running radarr as admin worked!!! thanks! but i would still like to have a clean solution like your task scheduler option :slight_smile:

sure, glad to help.

task scheduler.
i already posted the 'general' tab
trigger: use defaults
condition: use defaults,
settings: use defaults

okay sadly this isnt working for me
i looks like i have to start cmd / rclone and radarr by hand as admin :frowning:

and when it do it this way i nolonger can access the mount via file-explorer :frowning:

you must be making some kind of mistake.

by default, explorer.exe run with non-admin rights.

use task manager to verify, what username rclone mount command is running under


i also tried to leave change triggers to


but i also tried to leave it default

restarted pc after everychange

while using this method the drive isnt getting mount - atleast i cant see it in file explorer / radarr / and i can just start the .bat file again to mount the the drive, should be colliding if the task sheduler would have worked

  • you do not need to reboot to test, just run the task via task scheduler. get it working then set the trigger to start at system startup.

  • when you run a batch file as system user, the current working folder is c:\windows\system32
    when the script is run, it cannot find rclone.exe
    so either supply the full path to rclone.exe in the script, which i always do.
    for the action, you need to set the 'start in' folder

  • since the batch file run as system user, will be hidden from the desktop, you cannot see what is going on.
    you need to use a log file and read that to understand what is going on.

i already added rclone to my system variables so i thought this would be fine

"2020/05/30 16:09:42 NOTICE: Config file "C:\WINDOWS\system32\config\systemprofile\.config\rclone\rclone.conf" not found - using defaults
2020/05/30 16:09:42 Failed to create file system for "gmovie:": didn't find section in config file"

is what i get now with full rclone path

current .bat file

C:\ProgramData\chocolatey\bin\rclone mount gmovie: M: --cache-db-purge --buffer-size 32M --use-mmap --dir-cache-time 72h --drive-chunk-size 16M  --timeout 1h  --vfs-cache-mode minimal --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G > C:\mount\log.log 2>&1

when a program runs as different user, it uses a different profile.
so rclone cannot find the rclone.conf that is located inside your user profile

you need to use this flag

to find config file

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.