More special character issues

I realized there have been a couple of issues with special characters but it looks like many of them are closed. My issue might have already been fixed in a beta but I don’t think so. I am using 1.39 and when doing a sync (dry run) it shows there are a few files that need to be uploaded. I checked Google drive and the files are there with the same matching names but when rclone does the sync check is sees and displays the ó as ó and the ® as ® which results in the file names not matching.

This problem should be fixed in the beta version of rclone.

The issue you are referring to is probably #1675. It is caused by a bug in the drive API, which needs to be fixed by Google. Until than rclone has implemented a workaround to solve the problem.

Ah, ok, thanks. There were a couple report I saw about special characters. I wasn’t sure which, if any, I was experiencing.

Any particular version of the beta? I just used the one labeled as latest and I am still having the issue.

The latest beta should definitely have the fix.

What command are you trying to run? Can you give an example names that fail to compare?

I tried uploading a file named te®st.txt multiple times and rclone only copied it once.

One cause I could imagine is a locale configuration that does not support utf-8. What does locale print on your pc?

I tried both sync and copy as a dry run. Some examples were “Autómata”, “wsp®”. Oddly, I just went back to look at the files on source and they had been renamed to “Autómata” and “wsp®”. I’m 95% sure I did not so that but I’m not sure how that happened. I renamed the source files properly and it seems to be working. Rclone sees both source and destination correctly.

I use rclone to upload on a linux box but the box I am using to test and verify things are in sync is a Windows 10 box so the no ‘locale’ command. I did run ‘local’ from bash with the ‘Ubuntu for Windows’ but I don’t know if that is a valid test. Windows 10 shouldn’t have an issue with UTF-8 I don’t think anyway.

That looks like UTF-8 displayed on a latin1 console. Are you running these from CMD? Maybe it doesn’t display UTF-8 characters properly.