Montage Uptobox does not update new content

What is the problem you are having with rclone?

Hello. I mount my Uptobox drive with the following Rclone code:

rclone mount --vfs-cache-mode writes --allow-other --allow-non-empty --vfs-read-ahead=32M --buffer-size=64M Uptobox: /home/Uptobox

Everything works fine, however, if I put a new file in my Uptobox account, the mounted drive of Uptobox does not have that file. I have to unmount and remount the Uptobox drive so I can see that new file.

I don't know if I have to put some more flag to mount it and have it automatically update me with the data of my Uptobox account without having to unmount and mount the unit again

Run the command 'rclone version' and share the full output of the command.

rclone v1.57.0

  • os/version: ubuntu 20.04 (64 bit)
  • os/kernel: 5.13.0-27-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.17.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

hello and welcome to the forum,

by default, rclone will not notice the new files for five minutes, as documented here
"changes made directly on the cloud storage by the web interface or a different copy of rclone will only be picked up once the directory cache expires "

you can tweak the delay time using
--dir-cache-time duration Time to cache directory entries for (default 5m0s)

Hello. Now I have this line:

rclone mount --allow-other --allow-non-empty -v --vfs-cache-max-age 1m --transfers 16 --vfs-cache-mode writes --cache-dir=/home/user/cache / --fast-list Uptobox: /home/user/Uptobox

With this code I get it to update, but it takes a while for the changes in Uptobox to be made to my mounted Ubuntu drive. I don't know if the flag you indicated can make that time shorter. I was testing it, but I think I don't know how to put it.

I would also like that instead of loading that line in Terminal, it would load automatically when the computer starts or restarts.

Greetings and thank you

--fast-list - does nothing on a rclone mount, can remove it.

to have rclone noticed new files every one minute,use --dir-cache-time 1m
and using time paramters is documented at

many ways, for example,
--- use tmux or screen to keep the terminal session alive, even if you exit the ssh terminal
--- use cron or systemd to schedule rclone to run at boot time.

Thanks for the information. My code now is this:

rclone mount --allow-other --allow-non-empty -v --vfs-cache-max-age 1m --transfers 16 --vfs-cache-mode writes --dir-cache-time 1m --cache-dir=/home/user/cache/ Uptobox: /home/user/Uptobox

Let's see if you can explain to me how to do the systemd or cron thing to put the rclone mount when restarting the computer.

I'm new to Linux and have a lot to learn...


--allow-non-empty - best to remove that unless you are 1000% sure you need it.

cron is much simpler and can search the internet for how to guides.
for example,

Thank you very much for your help. I think I got it following your steps.
I've also put the cron in, with a @restart and my rclone mount line and it works.
I don't know if there is any flag that makes viewing an Uptobox file faster. Now if I play some content, it takes about 10 seconds to see it on Emby.
Again, thank you very much.


could be a lot of reasons, such as slow internet.
might try --vfs-cache-mode full

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.