Missing options on headless setup - Which option should I pick?

What is the problem you are having with rclone?

I did a test setup on my main machine and got Google Photos sync to work. However, on headless I don't see the option to setup Google Photos. I understand this is because I'm unable to open a browser to authenticate, but when following the instructions in https://rclone.org/remote_setup/, I fail to understand which option to pick in order to get to the "use auto config" option.

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Raspbian on a pi zero. Lite install.

Which cloud storage system are you using? (eg Google Drive)

Google Photos

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

Can you share a screenshot?

It would be number 14 in my Manjaro system. It's missing a few options, here.

What does

rclone version


rclone v1.53.1

  • os/arch: linux/amd64
  • go version: go1.15.2

If you are missing options, the version you are sharing does not match up.

On 1.53.1, you'd see:


That's an old version screenshot.

That would make sense. Except for the fact that my version number matches the latest published version. I guess it can be an issue with the raspbian repository... I did a simple "sudo apt-get install rclone". I'll try to install from source, or something. Thanks

Downloading from a repository is not recommended as you don't know what you are getting.

https://rclone.org/downloads/ is the recommended way.

The armv6 version works fine. Thanks for the assist.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.