Missing directories with rclone lsd and rclone mount

.

What is the problem you are having with rclone?

I use rclone to mount an encrypted openstack container, inside which there are 109 directories containing a bunch of text files. Over time, the number of directories has not changed, but the content of them has increased.
Recently I noticed that on the mounted container I no longer see all the directories, but I only see 24. I get the same behaviour if I run rclone lsd, but I can see all directories if I run rclone lsf -R -d.
I tried to change the shard parameter in ceph, moving it from 1 to other number and I saw that rclone lsf -R also returned fewer directories than the existing ones, but I haven't been able to determine a correlation between shard and number of directories. The shard parameter does not seem to affect the output of rclone lsd.

Run the command 'rclone version' and share the full output of the command.

rclone v1.57.0
- os/version: ubuntu 18.04 (64 bit)
- os/kernel: 4.15.0-96-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.17.2
- go/linking: static
- go/tags: none

Same behaviour with version 1.50.1

Which cloud storage system are you using? (eg Google Drive)

Swift

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsd  nfCryptNoDir:

The rclone config contents with secrets removed.

[nfCtObj]
type = swift
auth = <auth>
auth_version = 3
region = <region>
interface = private
application_credential_id = <application_credential_id>
application_credential_secret = <application_credential_secret>

[nfCryptNoDir]
type = crypt
remote = nfCtObj:nfCryptNoDir
filename_encryption = off
directory_name_encryption = False
password = <password>

A log from the command with the -vv flag

2022/01/13 13:50:06 DEBUG : rclone: Version "v1.57.0" starting with parameters ["rclone" "lsd" "nfCryptNoDir:" "-vv" "--log-file=rclone.log"]
2022/01/13 13:50:06 DEBUG : Creating backend with remote "nfCryptNoDir:"
2022/01/13 13:50:06 DEBUG : Using config file from "/home/ubuntu/.rclone.conf"
2022/01/13 13:50:06 DEBUG : Creating backend with remote "nfCtObj:nfCryptNoDir"
2022/01/13 13:50:07 DEBUG : 4 go routines active

Thanks!

hello and welcome to the forum,

did you search the forum?, take a good read of this topic.
https://forum.rclone.org/t/cant-list-1-directory-in-bucket-so-sync-doesnt-work-properly/28269

so not sure this is a rclone bug.

Thank you for your help, I'm checking your link. I switched to "help and support", since it's not an rclone bug.