Mergerfs , Radarr, Sonarr and Plex


Regarding post:

If we take his example:
~/Stuff/Local - Local Mount
~/Stuff/Mount - GDrive Mount

/home6/acmojado/Stuff/Local:/home6/acmojado/Stuff/Mount /home6/acmojado/MergerFS

Folders located in MergerFS:

Everything should point to the MediaFS folder when you download, but do you also ask Plex to look in that folder as well or do you point plex to your mount directory which will have new data uploaded over night via your upload script?

If you use the Mount folder ,what do you do if you want to see something asap after download? It will first be available over night as I can understand via your upload script .

If I need hardlinks to work, I need to download to MergerFS. Then I see the file downloaded in Local.

But what I can't get to work it:
Download client folder is /MergerFS

So when I download i.e Happy Feet to /MergerFS/Happy Feet then Happy Feet is placed under /Local/Happy Feet and not /Local/Animations/Happy Feet

How do I manage this? :slight_smile:

I just tried to download to rutorrents download folder /home/plex/rutorrrent/download

After that, I can see that my movie is correctly placed under my MergerFS folder and Local.
In Radarr the movie folder is :

The only problem is that its not hardlinked, even though the option in Radarr is enabled.
If I remove the file from rutorrent and erase it, the renamed folder and files are still present in my MergerFS and Local

What am I doing wrong :frowning:

I'm not sure what you mean as everything is available about 15 seconds after an upload is finished as that's based on polling time on the remote.

I can't quite follow what you are doing as mergerfs just combines mounts. I have /local and /GD and combine them so when I write to /gmedia/Movies/Happy Feet, it puts it with the path as well. I think you are asking a Radarr question but I'm not quite sure.

Good morning Ani :slight_smile:

If Happy Feet is called Happy.Feet.Year.blabla.blueray.DK something , im having problems when its done downloading via Radaar

If I chose the MergerFS folder , I will have Happy.Feet.Year.blabla.blueray.DK, and then a post processed one which is rename to Happy Feet Year . So in Local I will see Happy.Feet.Year.blabla.blueray.DK which has been downloaded in MergerFS, but also the second one due rename process.

I will then have to uploads two folders which will upload to gdrive Happy.Feet.Year.blabla.blueray.DK and Happy Feet Year .

No matter which settings I make in Radarr ( dont rename folders etc ) , it keeps making a renamed folder version so I have two separate folders.

Forgot about the polling , of course :slight_smile: , so no issues there.

I use Radarr for media management and movement of files.

If the path is right for the movie, it will move it to the right path that you have set.

Everything for me points to mergerfs so if it's local or on my rclone mount, it's always the same path.

It sounds like you have something set wrong in Radarr or in your clients and you are getting duplicates.

Hi again

Thanks for your fast reply Ani , appreciated.

I wrote with the support of Radarr, and it seems that Radarr will no matter what rename the movie folder name, you can keep the file name intact, but the folder name will rename no matter what. A bit odd.
They also told me that the download and the post process should'nt be in the same folder..

So what I did now (which works now :slight_smile: . Just using the standard rutorrent download folder. Once downloaded it will move the movie to the MergerFS folder in the respective movie folder. And that movie is now shown in my Local folder which is being uploaded to gdrive after xx of time.

The only problem I have now is when I use move and have excludes of i.e some type or .srt files, they are still present in the folder ofc. Added --delete-empty-src-dirs to my scripts - will remove the empty folders, but those folders which isnt empty due the exclude will not be deleted?

How can I tell the system to delete the folders even though it havent moved them after upload from the exclude?

When Radarr moves to the final destination, it only moves what it needs and removes extras. I only upload the final locations of Sonarr/Radarr and I leave all the torrent stuff alone.

That should be another setting to clean that up.

Yea I also enabled the "Import Extra Files" , added srt.

I see your point :slight_smile: , gonna look into that tonight.

Thanks a million for your feedback.