Mega login issue, Failed to create file system for "megatwo:": couldn't login: Block decryption failed


#1

Hello there, i have two mega accounts connected to rclone, and i occasionally use rclone mount, to explore the data on them, they both worked flawlessy up until today, where i tried to mount one of the accounts and got this error can’t login to mega, Failed to create file system for “megatwo:”: couldn’t login: Block decryption failed

After getting this error, i tried mounting my other account, it mounted without error. i then updated my version of rclone to the 1.45 readded the problematic remote and tried again, the command hung for a bit, then gave me the same error as before.

Any command i try and run on that remote just hangs. not just rclone mount

Any help would be great, lmk if you need any more information, thanks


#2

This has come up in the issues: https://github.com/ncw/rclone/issues/2709

Where the suggestion was that it is to do with shared folders not being handled properly.


#3

Thank for the Advice, it’s kinda odd if that’s the issue because i was using the account with a shared folder for a while with no issue, however I’ll definitely unshare the folder and try again. I’ve also ran into another issue/bug when trying to use rclone, this was with the other account after i imported a decent amount of data to it.

C:\Users\thoma\Desktop\rclone-v1.45-windows-amd64
λ rclone.exe mount megaone: X:
panic: runtime error: index out of range

goroutine 1 [running]:
github.com/ncw/rclone/vendor/github.com/t3rm1n4l/go-mega.(*Mega).addFSNode(0xc0001a82a0, 0xc00094ea90, 0x8, 0xc00094ea98, 0x8, 0xc00094eaa0, 0xb, 0x0, 0xc00062c960, 0x2b, …)
C:/gopath/src/github.com/ncw/rclone/vendor/github.com/t3rm1n4l/go-mega/mega.go:649 +0x1543
github.com/ncw/rclone/vendor/github.com/t3rm1n4l/go-mega.(*Mega).getFileSystem(0xc0001a82a0, 0x0, 0x0)
C:/gopath/src/github.com/ncw/rclone/vendor/github.com/t3rm1n4l/go-mega/mega.go:759 +0x363
github.com/ncw/rclone/vendor/github.com/t3rm1n4l/go-mega.(*Mega).Login(0xc0001a82a0, 0xc0001403c7, 0x1a, 0xc0002afc20, 0xd, 0x0, 0x0)
C:/gopath/src/github.com/ncw/rclone/vendor/github.com/t3rm1n4l/go-mega/mega.go:500 +0x527
github.com/ncw/rclone/backend/mega.NewFs(0xc00002c0f8, 0x7, 0xc00002c0f8, 0x0, 0x141e8a0, 0xc0001555f0, 0x0, 0x0, 0x0, 0x0)
C:/gopath/src/github.com/ncw/rclone/backend/mega/mega.go:207 +0x5a0
github.com/ncw/rclone/fs.NewFs(0xc00002c0f8, 0x8, 0xe24917, 0x10bdbc0, 0x0, 0x12c60a1)
C:/gopath/src/github.com/ncw/rclone/fs/fs.go:1050 +0xbc
github.com/ncw/rclone/cmd.newFsDir(0xc00002c0f8, 0x8, 0x12e, 0xc000332a80)
C:/gopath/src/github.com/ncw/rclone/cmd/cmd.go:134 +0x54
github.com/ncw/rclone/cmd.NewFsDir(0xc0001242e0, 0x2, 0x2, 0xc0001242e0, 0x2)
C:/gopath/src/github.com/ncw/rclone/cmd/cmd.go:146 +0x48
github.com/ncw/rclone/cmd/mountlib.NewMountCommand.func1(0xc000346c80, 0xc0001242e0, 0x2, 0x2)
C:/gopath/src/github.com/ncw/rclone/cmd/mountlib/mount.go:223 +0xc7
github.com/ncw/rclone/vendor/github.com/spf13/cobra.(*Command).execute(0xc000346c80, 0xc0001241a0, 0x2, 0x2, 0xc000346c80, 0xc0001241a0)
C:/gopath/src/github.com/ncw/rclone/vendor/github.com/spf13/cobra/command.go:766 +0x2d3
github.com/ncw/rclone/vendor/github.com/spf13/cobra.(*Command).ExecuteC(0xf79e40, 0x0, 0x0, 0x0)
C:/gopath/src/github.com/ncw/rclone/vendor/github.com/spf13/cobra/command.go:852 +0x304
github.com/ncw/rclone/vendor/github.com/spf13/cobra.(*Command).Execute(0xf79e40, 0xc000034178, 0x0)
C:/gopath/src/github.com/ncw/rclone/vendor/github.com/spf13/cobra/command.go:800 +0x32
github.com/ncw/rclone/cmd.Main()
C:/gopath/src/github.com/ncw/rclone/cmd/cmd.go:482 +0x4d
main.main()
C:/gopath/src/github.com/ncw/rclone/rclone.go:13 +0x27

C:\Users\thoma\Desktop\rclone-v1.45-windows-amd64
Λ

Perhaps it’s due to the large amount of data i have on the account?

Thanks again


#4

I’ll be interested to hear the results.

Can you please make a new issue on github with that in so I don’t forget about it - it definitely shouldn’t do that!

However that may be a clue as to what is going on which is good!