Max-duration time is updated on retry

What is the problem you are having with rclone?

When using max-duration with retries > 1, if an error occurs, the duration is updated to $now+duration on the retry

The log starts by showing

2024/02/21 15:05:26 INFO  : Local file system at /cephfs2/toby/test0: Transfer session HARD deadline: 2024/02/21 15:25:26

and later, on the retry, it shows:

2024/02/21 15:05:47 ERROR : Attempt 1/5 failed with 630 errors
2024/02/21 15:05:57 INFO  : Local file system at /cephfs2/toby/test0: Transfer session HARD deadline: 2024/02/21 15:25:57

[The errors are due to broken symlinks, but as this is for a backup, it's ok, they'll become fixed if/when I need to restore.]

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.1

  • os/version: almalinux 8.9 (64 bit)
  • os/kernel: 4.18.0-513.11.1.el8_9.x86_64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.5
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

None, local -> local.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone -P -vv --max-duration=20m --create-empty-src-dirs --metadata --links --retries 5 --retries-sleep 10s --log-file duration.log sync /cephfs/toby/10085_test2/CtfFind/job011 /cephfs2/toby/test0/

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

rclone config redacted
2024/02/21 15:35:25 NOTICE: Config file "/root/.config/rclone/rclone.conf" not found - using defaults
; empty config
### Double check the config for sensitive info before posting publicly

A log from the command that you were trying to run with the -vv flag

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.