Max-age / min-age RFC3339 format rejected

What is the problem you are having with rclone?

RFC3339 format not accepted in --max-age and --min-age

What is your rclone version (output from rclone version)

rclone v1.54.0
os/arch: linux/amd64
go version: go1.15.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Red Hat Enterprise Linux Server release 7.9 (Maipo)
Architecture: x86-64

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone ls -vv --exclude '.git/**' Dropbox:/Documents/ --max-age "2006-01-02T15:04:05Z07:00"

A log from the command with the -vv flag

2021/02/10 13:21:52 Fatal error: invalid argument "2006-01-02T15:04:05Z07:00" for "--max-age" flag: parsing time "2006-01-02T15:04:05Z07:00": extra text: "T15:04:05Z07:00"

The example in the docs is wrong. Z is only used for UTC+0. Your timestamp should either be
2006-01-02T15:04:05Z or 2006-01-02T15:04:05+07:00.


Submitted PR
to reflect correction from @x0b


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.