Mandb error when running script install on Synology DS918+

Firstly I’m way out of my depth with this and hopefully am just missing something obvious.

As per the title, I’m ssh’d into my DS918+ running Synology’s DSM OS with an admin account and root access.

When I run

curl | sudo bash

It downloads momentarily then displays the following text

Everything is Ok

Folders: 1
Files: 5
Size: 27317942
Compressed: 8684781
bash: line 153: mandb: command not found

and from here I’m not sure what I should be doing. I found this similar thread but after reading it I’m still not sure what to do next - if rclone is installed then how to run it or if it failed to install due to that error how to resolve that. I believe the install has failed.

In the I can see the part of the script that has that line is

case $OS in
cp rclone /usr/bin/
chmod 755 /usr/bin/
chown root:root /usr/bin/
mv /usr/bin/ /usr/bin/rclone
mkdir -p /usr/local/share/man/man1
cp rclone.1 /usr/local/share/man/man1/

Can someone please point me in the right direction? I’m close as I have my rclone .config file setup by a friend however he isn’t familiar with Synology’s DSM. If I can just get the install done then I should be able to pick up where we left off by utilizing that config.

Thank you

I would say rclone is probably installed, just without the man page, so it should work fine now. Does it?

On further investigation - You’re correct. Just needed to place my config file in the relevant location and then ssh in to configure it. The mandb error can be safely ignored it appears. Thanks

1 Like