Main drive filling up when copy/pasting


I'm kinda new to this. I followed a few reddit guides and have successfully set up rclone. It is connected to a google drive account. Rclome runs as a service with nssm, this is on windows 10 by the way. My issue is whenever copy a file to the mounted drive, space is taken up on my main drive as well. I read that this is the vfs cache, but I don't know how to clear it. I saw someone say its in config but i cant find any files except config there. Any idea how i would go about clearing it? my vfs is set to --vfs-cache-mode writes.

Thank You

hello and welcome to the forum,

when you posted, you should have been ask for the following info.

What is the problem you are having with rclone?

What is your rclone version (output from rclone version)

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

I cant seem to find the files that are cached locally when i copy and paste to the mount

rclone v1.53.1

  • os/arch: windows/amd64
  • go version: go1.15

Using Google Drive

Not running any specific command
"If run with -vv rclone will print the location of the file cache. The files are stored in the user cache file area which is OS dependent but can be controlled with --cache-dir or setting the appropriate environment variable."

--vfs-cache-max-age duration             Max age of objects in the cache. (default 1h0m0s)

Issue is if i type rclone.exe -vv it just gives me a page about available commands

add -vv to the rclone mount command.

2020/10/06 15:43:20 DEBUG : vfs cache: root is "\\\\?\\C:\\Users\\user01\\AppData\\Local\\rclone\\vfs\\gdrive-a1b2"
2020/10/06 15:43:20 DEBUG : vfs cache: metadata root is "\\\\?\\C:\\Users\\user01\\AppData\\Local\\rclone\\vfs\\gdrive-a1b2"

I got the -vv comand to work, it doesnt show a vfs cache location though.

Here is the arguments

mount --allow-other --dir-cache-time 2h --drive-chunk-size 64M --log-level INFO --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off gdrive: X: --config "C:\Users\User1.config\rclone\rclone.conf" --vfs-cache-mode writes.

Even if i clean up disk space it seems to fill up again by itself

With writes, it writes the file to the local disk first and uploads it. It's going to use local disk space based on your configuration.

If you check the log, it will show you were the cache dir as l am not sure offhand on Windows other than it looks like your user1.config\rclone directory.

Yeah, is there any way to make it delete the files from disk though?

Also i cant seem to find the logs

It deletes after it uploads and the age expires, which is 1 hour by default:

 --vfs-cache-max-age duration             Max age of objects in the cache. (default 1h0m0s)

You'd have to add the log option --log-file rclone.log

Hmmm, my hard drive has been full all night though, it doesn't seem like it cleaned up after an hour. --dir-cache-time 2h was originally 72h then i switched to 2h, if that makes a difference

dir-cache-time would not have any impact.

You'd have to post a log though as it's just guessing on the issues.

The service rclone has been started.
2020/10/07 14:14:36 INFO : vfs cache: cleaned: objects 3 (was 3) in use 0, to upload 0, uploading 0, total size 0 (was 0)
2020/10/07 14:15:06 INFO : DARLING in the FRANXX/Season 1/[HorribleSubs] Darling in the FranXX - 01 [1080p].mkv: vfs cache: queuing for upload in 5s
2020/10/07 14:15:06 INFO : DARLING in the FRANXX/Season 1/[HorribleSubs] Darling in the FranXX - 01 [1080p].mkv: vfs cache: queuing for upload in 5s

And now i have less than 5gb free on my c drive

Actually i think i know what might be happening. Im queueing up too many files at a time and once i see them on the mount i thought they were uploaded. This doesnt seem to be the case as I'm pre sure they look like they are there but infact they are queed for upload from the vfs cache. Come to think of it my hard drive did suddenly go back up to 50gb free yesterday afternoon

So on the mount files are uploaded one at a time.
If you want to move a lot of files, it's better to use rclone copy and copy directly to the remote rather than the mount.

Alright thanks. Is it possible to change the vfs cache location though?

Sure is.


and point to the location you want.

1 Like

Alright thanks. I moved the folder to another drive so my main can be free. Now ill just delete the existing vfs cache manually and restart the uploads

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.