macOS Catalina and Fuse Mount error

ahh thank you, I'll try that now

Doesn't look like debug made any difference:

rclone mount -vv  --debug-fuse media: ./rclone_mount
2020/03/18 08:32:21 DEBUG : rclone: Version "v1.51.0" starting with parameters ["rclone" "mount" "-vv" "--debug-fuse" "media:" "./rclone_mount"]
2020/03/18 08:32:21 DEBUG : Using config file from "/Users/username/.config/rclone/rclone.conf"
2020/03/18 08:32:22 DEBUG : Encrypted drive 'media:': Mounting on "./rclone_mount"
2020/03/18 08:32:22 Fatal error: failed to mount FUSE fs: exit status 1

I'll try the uninstall process.

And what do you know, removed the osxfuse that homebrew installed and installed using the developers dmg. working fine now.

Thanks all for your help.

Well that is a little surprising, but if it works, lets roll with it!

Do you think it might be worth reporting a bug on the brew package?

When you used the brew package, did you go through and enable the kernel extensions? It sounds like you installed, but didn't really enable it.

yeah I'll look into raising an issue there

seems like i have same problem. Fuse installed

bash-3.2$ sudo rclone --vfs-cache-mode writes mount --allow-non-empty onedrive_remote: ~/Documents/OneDrive/Movies 

sudo: setrlimit(8): Invalid argument

2020/04/05 13:17:19 mount helper error: mount_osxfuse: mount point /Users/alex/Documents/OneDrive/Movies is itself on a OSXFUSE volume

2020/04/05 13:17:19 Fatal error: failed to mount FUSE fs: mount_osxfusefs: exit status 64

That looks like you are trying to mount an rclone mount onto a place where it is already mounted or part of another mount?

You meen, that mounted folder for media shouldnt be in original onedrive folder?

You can't mount something on top of an existing rclone mount.

Do you have an existing rclone mount?

Yes. I'd configured onedrive mount.
Now I deleted OneDrive app and want to mount to another folder.

alex@Alex-MacBook-Air ~ % sudo rclone mount --allow-non-empty onedrive_remote:/ /Movies/
sudo: setrlimit(8): Invalid argument
2020/04/06 21:53:56 mount helper error: mount_osxfuse: /Movies: Read-only file system
2020/04/06 21:53:56 Fatal error: failed to mount FUSE fs: mount_osxfusefs: exit status 64

Copied directly from Apple KB - About the read-only system volume in macOS Catalina*

With macOS Catalina, you can no longer store files or data in the read-only system volume, nor can you write to the "root" directory ( / ) from the command line, such as with Terminal.

macOS Catalina runs in a read-only system volume, separate from other files on your Mac. When you upgrade to Catalina, a second volume is created, and some files may move to a Relocated Items folder.

macOS Catalina runs on a dedicated, read-only system volume called Macintosh HD. This volume is completely separate from all other data to help prevent the accidental overwriting of critical operating system files. Your files and data are stored in another volume named Macintosh HD - Data. In the Finder, both volumes appear as Macintosh HD.

enter image description here

You can just use a simple mount command and pick a directory that exists most likely and is also empty.

I used a test directory in my downloads:

cd Downloads
mkdir Test
rclone mount gcrypt: /Users/textere/Downloads/Test -vv

Running with sudo means you have to configure rclone under root and do your config there.

Non empty is just bad as it allows for over mounting and things to be hidden.

1 Like

I understand this.
Now I created folder on /System/Volumes/Data/FOLDER_NAME and tried to mount onedrive.

Get this answer :frowning:
2020/04/06 22:11:34 INFO : One drive root '': poll-interval is not supported by this remote

I'm going crazy :roll_eyes:

That's a normal message for OneDrive as it doesn't support polling.

1 Like

And what should I do now? :confused:

Use you mounted remote? Is something not working?

Yes. I restarted my mac and start to run rclone again.

alex@Alex-MacBook-Air data % sudo rclone mount -v onedrive_remote:/Movies/ /System/Volumes/Data/Movies_OD/
sudo: setrlimit(8): Invalid argument
2020/04/06 22:27:30 Fatal error: Directory is not empty: /System/Volumes/Data/Movies_OD/ If you want to mount it anyway use: --allow-non-empty option

Here mac os asked allow to server disk.
alex@Alex-MacBook-Air data % sudo rclone mount --allow-non-empty -v onedrive_remote:/Movies/ /System/Volumes/Data/Movies_OD/
sudo: setrlimit(8): Invalid argument
2020/04/06 22:28:29 mount helper error: mount_osxfuse: mount point /System/Volumes/Data/Movies_OD is itself on a OSXFUSE volume
2020/04/06 22:28:29 Fatal error: failed to mount FUSE fs: mount_osxfusefs: exit status 64
alex@Alex-MacBook-Air data %

And nothing else

As I had mentioned above, you want to make sure the directory is empty. If you are going to use allow-non-emtpy, things are not going to go well for you.

If you keep over mounting, things are going to be confusing.

Reboot.
Make sure directory is empty you are mounting to.
Run the rclone mount command.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.