MAC resource fork files not copying


#1

Hello, we use a Red Hat Linux (5.8 Tikanga) to store our daily working files. A large portion of our environment are running MAC workstations. Sierra 10.12 and up. I am trying to copy/archive up to box.com our closed job folders. Many of these folders contain things like fonts which are important to the job. I’ve installed and setup Rclone on both the linux server as well as my own mac workstation and tried running the Rclone copy procedure on a couple of example folders that contain fonts. The copy works however the font files corrupt because they seem to lose the resource fork. I’m testing this by just downloading the font folder from box.com back down to my mac workstation. The font files should be showing about 30kb in size (as per the mac finder window) but they show 0kb once downloaded. They also lose their “identity” as font files.

I’ve tried to Rclone from both the linux server as well as from my mac workstation but the results continue to be the same.

Any assistance would be great. Thanks!


#2

I don’t have a mac so consider me a mac noob!

I think what you’d want to happen is that rclone would read the files and convert the data and the resource fork into two files in Apple Double format.

I think reading the resource fork should be as simple as using “filename/rsrc”. No idea how you write it!

Or maybe what is required is that rclone preserves extended attributes somehow.

There is an issue about this here: https://github.com/ncw/rclone/issues/1710 which looks related.

Any thoughts?


#3

Thank you for the info. Unfortunately, I continue to have the same issues no matter what options I put on the rclone command or how I mount the drive. Very frustrating.


#4

Yes, rclone isn’t going to work with resource forks without a bit of development.