Mac OS Big Sur mount error

Hello guys ,
I am using rclone on catalina with mount ==> OneDrive ==> works Fine.
But , In my other mac which run big Sur 11.1 I try the same mount

against the same OneDrive I get an error how look like this :

koby@Kobys-Mac-mini ~ %
koby@Kobys-Mac-mini ~ % rclone mount --vfs-cache-mode full OneDrive: MksoftOneDrive
2021/01/17 11:19:17 NOTICE: macOS users: please try "rclone cmount" as it will be the default in v1.54
2021/01/17 11:19:17 Fatal error: failed to mount FUSE fs: cannot locate OSXFUSE

My work Spec:

Old Mac ==> Catalina 10.15 (Intel / python 3.8 /Fuse ==> Can't find the version)
New Mac ==> Big Sur (11.1) (Apple M1 / python 3.9.1 / Fuse Ver 4.05)
On both mac I'm using Rclone Ver 1.53.3
Fuse Ver 4.0.5 does exist on new mac mac.

Please advice.

Best Regards ,
Koby Pleg Hen

You need to replace 'mount' with 'cmount'

Hello ,
Please take a look....

It does not recognize the command.
Best Regards ,
Koby Peleg Hen

You need to install the latest rclone.

Hello ,
Please take a look ....

Rclone already installed on the latest version.
Even due , it does not recognize the command.

Best Regards ,
Koby Peleg Hen.

Can you please type this and share the same output:

felix@gemini:~$ rclone version
rclone v1.53.3
- os/arch: linux/amd64
- go version: go1.15.5


felix@gemini:~$ sudo rclone version
rclone v1.53.3
- os/arch: linux/amd64
- go version: go1.15.5

Here is for you to see.

Screen Shot 2021-01-17 at 17.14.25

Install the MacOS download:

Just to be clear, you're suggesting OP use the x86 version rather than the ARM one? They are running a new ARM, M1 Mac.

I seem to recall people saying it would worth through Rosetta2. I wish I had first-hand experience on this.

I did that , sadly the song remain the same....
Please take a look.....

Yes, that's what I linked as it's auto install the ARM version, which I believed did not have the CMOUNT compiled into it as there isn't a native new mac version yet:


Strange as I'm not sure offhand as I don't have a new Mac to test with unless you'd like to send me one :slight_smile:

@ncw - any thoughts on the cmount not showing up as from what I thought, it was part of 1.53.3

Here is an issue with lots of discussion

It is possible to build an ARM rclone which runs with Apple M1, but it requires the beta version of the Go compiler.

For the time being I'd suggest using the AMD64 version which I think works OK.

Note that the version of rclone from brew doesn't have cmount so you'll need the version of rclone from for that.

I don't have a mac to test with unfortunately, though my daughter has one on order and maybe (if I ask really nicely) she will lend it to me for a few hours (unlikely, but you never know!).

Right - I linked the version MacOS AMD64 version, which I thought would have cmount compiled into it, but based on the version check (looks right to me), there doesn't seem to be CMOUNT or is that the wrong one installed?

It should, yes. I downloaded and checked - it definitely has cmount and its supporting library cgofuse compiled in - I can tell from the strings in the binary.

I suspect that might be the one from brew, but I'm not sure

Hello Guys ,
Finally good news.
I manage to enable it to work.
I install from install it manually by copying the rclone to Rclone Directory , Tested with "cmount" and it does work.
I do need to find why it is need to be run as ./rclone.
But It is working - was needed to do restart to enable the Systems Extension on the recovery mode + one restart.
The curl install ==> did not work.
Thank you all guys.

Best Regards,
Koby Peleg Hen

That is saying run the command from your current working directory.

Most binaries get install in /usr/bin or /usr/local/bin

If you've been mixing versions and installs, you probably want to do something like:

find / -name rclone

and see where it is and remove old/wrong/bad versions.

That's because it grabs the ARM version which isn't compiled for CMOUNT as the M1s are not 'officially' supported yet until that issue above gets resolved so it runs in compatibility mode.

Yep, I have more be more clear in validating things as I can see a few question I could have worded better to make sure the right binary was being executed.

Badly , I try few more time and it seems the the mac got stuck - no finder...
Something regard to the fuse , it is seem not cook enough.

Hi , There any options avail for Mac Big Sug users,
I ask that because no other solution is working as expected so far.
Even not the default "Microsoft OneDrive".
I also tried to remove the newest Fuse Ver 4.0.5 and installed the Ver 3.11.2.
On each one of them no success so far.
I think the all echo systems which name MacOs Ver 11.1 is not cooked enough.
That is my filling , since on Mac Os Cataline 10.15 every thing is working great and very stable. If I Could install on my M1 mac Catralina....

I am not following what the issues is.

There already is the issue for M1 support as it isn't closed:

Running in the AMD64 executable should be fine though and it doesn't use fuse installed from my understanding.

If you can validate what version you are running and share a debug log of the issue, we can help out.

try mounting with this flag: --disable About
it solved the issue for me Finder (and the whole OS) getting stuck on M1

I'm using a self-compiled Rclone (v1.54.0-DEV) for arm and macfuse 4.0.5