Lsf - two simultaneous parameters not working

I’m trying to list the contents of an encrypted B2 remote with the obfuscated file name option.

If I use only the --crypt-show-mapping parameter, the files are listed and shows the encrypted name, but only the root folder.

2018/08/06 19:28:16 DEBUG : rclone: Version "v1.42-030-g793f594b" starting with parameters ["RCLONE" "lsf" "b2:bucket"  "--fast-list" "--crypt-show-mapping" "-vv"]

If I use only the --recursive option, it lists all the contents of the subfolders, but - obviously - does not show the encrypted name of the files.

2018/08/06 19:31:09 DEBUG : rclone: Version "v1.42-030-g793f594b" starting with parameters ["RCLONE" "lsf" "b2:bucket"  "--fast-list" "--recursive" "-vv"]

However, if I use both parameters at the same time it returns an error:

Error: unknown flag: --recursive --crypt-show-mapping

What am I doing wrong?

This works for me

rclone -vv lsf --recursive --crypt-show-mapping secret:

What does your command line look like?

The command line is “mounted” by a script, I modify only the parameters.

So I just change the parameter between:

--recursive --crypt-show-mapping

The complete command has these parameters (names edited):

 rclone lsf B2-crypted-remote:bucket 
 --filter-from Rclone-filter.txt
 --stats 15s
 --stats-log-level DEBUG

I suspect your script is passing these in as a single parameter somehow.

So if you do

rclone -vv lsf "--recursive --crypt-show-mapping" secret:

You’ll get that error

2018/08/08 09:32:34 Fatal error: unknown flag: --recursive --crypt-show-mapping

Hit the nail on the head…

Only a small ":flushed:

Thanks a lot! :wink: :+1: