Lost mount when rebooting, and slow speed

What is the problem you are having with rclone?

I am trying to use rclone to sync my Google Drive with my laptop. I am running into two issues:

  • When I reboot my laptop, my mounts are gone, and I need to run rclone mount GDrive: ~/rclone-GDrive again, after which files start downloading anew. This seems unoptimal for workflow, as my GDrive has ~20GB of data, which takes about an hour to download every time. I wonder: Is this the intended behavior? I was hoping that once I have rclone set up, this would work the way other desktop clients do (I am thinking Dropbox here).

  • Even after downloading, speeds are very slow. I was able to recreate this in a MWE as follows:

    • I create a file rclonetest on my GDrive. It contains a 3.6MB test.pdf file (a presentation with 24 slides).
    • I create the remote GDrive-test which treats rclonetest as its root file; I did so following the instructions following the instructions found here to the best of my ability (I do create my own client_id and secret). The command rclone ls GDrive-test: outputs 3778506 test.pdf, as expected.
    • I make the directory rclone-GDrive-test.
    • I run rclone mount GDrive-test: ~/rclone-GDrive-test, and then open test.pdf. It takes ~30 seconds for the file to open; the same happens after closing and reopening. The file opens in ~1second when opening from my Downloads folder.

As you might tell from the above my background is not very strong, so if you could be extra clear with your instructions I would very much appreciate it. Thanks for your time.

Run the command 'rclone version' and share the full output of the command.

rclone v1.63.1
- os/version: ubuntu 22.04 (64 bit)
- os/kernel: 6.2.0-26-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.20.6
- go/linking: static
- go/tags: none

Are you on the latest version of rclone? You can validate by checking the version listed here: Rclone downloads
--> I believe this is the latest version as of Aug2023.

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Does not apply

The rclone config contents with secrets removed.

type = drive
client_id = XXXX
client_secret = XXXX
scope = drive
root_folder_id = XXXX
token = {"access_token":"XXXX","token_type":"Bearer","refresh_token":"XXXX","expiry":"XXXX"}
team_drive = 

(all XXXX are redacted)

A log from the command with the -vv flag

Does not apply.

For mount to work you have to run rclone mount command.

You do not have to do it manually - use your OS features. For example for linux I recommend setup systemd service. You can find plenty of examples on this forum and google.

To achieve cached reads you have to use VFS, e.g.:

rclone mount GDrive-test: ~/rclone-GDrive-test --vfs-cache-mode full --vfs-cache-max-size 250G

This allowed me to make a lot of progress. I am having issues setting up systemd, seemingly related to permissions. Follow-up question here. Thank you.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.