Lost config file. Have password + salt but unable to decrypt


#1

I’ve lost my config file.

It wasn’t backed up but I had saved the password and salt. I’ve just gone through and tried config to create a new file but after entering my password & salt I am unable to decrypt. Rclone is working fine but I’m getting the encrypted folder and filenames. eg 1m6aiu6ab9rnu7ogup2lejuj9s

This is with Google Drive. Maybe I noted the wrong password & salt? Am I screwed?


#2

My guess is that you are looking at the base remote so the encryption isn’t being applied. Check rclone ls on the crypt remote.


#3

I see that makes sense. Below is my config.

[GDrive]
type = drive
client_id = 
client_secret = 
service_account_file = 
token = <redacted>

[Encrypted]
type = crypt
remote = Crypt:Encrypted
filename_encryption = standard
directory_name_encryption = true
password = <redacted>
password2 = <redacted>

The command I was using was ‘rclone lsd GDrive:Encrypted’. If I try ‘rclone lsd Crypt:Encrypted’ I get the error “Failed to create file system for “Crypt:Encrypted”: didn’t find section in config file”.

It’s been so long since I’ve tried to understand the cli and I used to copy and paste the commands from a text file (which I also lost) so maybe I’m just using it incorrectly?

EDIT - If it helps within Google Drive I have a folder called Encrypted whose name is not encrypted. All the folders inside the Encrypted folder are encrypted


#4

You should be doing rclone lsd Encrypted: Maybe that’s your problem? I’d give that a try.

rclone treats encrypted shares as their own share, from the command line, think of them as completely separate. What’s in the square brackets [] is what goes before the colon : nothing else.

Good luck, I hope you get your stuff back,
jedi453


#5

haha yes I had just worked that out myself just before you posted this. I feel like a bit of an idiot but at least my 24TB of data is now accessible =)


#6

No problem! Glad you got your stuff back!
jedi453