List files by using min-age and max-age gives error

What is the problem you are having with rclone?

I want to list all files between --min-age and --max-age

Run the command 'rclone version' and share the full output of the command.

rclone v1.63.1

  • os/version: Microsoft Windows 11 Pro 22H2 (64 bit)
  • os/kernel: 10.0.22621.1702 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.20.6
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Hetzner storage

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone.exe ls hetzner-storage:myfiles --min-age=2023-08-01 --max-age=2023-09-01

The rclone config contents with secrets removed.

type = sftp
host =
user = xxxxxxxxxxxxxx
port = 22
pass = aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
shell_type = unix
md5sum_command = md5 -r
sha1sum_command = sha1 -r

A log from the command that you were trying to run with the -vv flag

2023/09/05 18:03:47 DEBUG : --min-age 1.1917546185496528M to 2023-08-01 00:00:00 +0300 EEST m=-3089027.844497199
2023/09/05 18:03:47 filter: --min-age can't be larger than --max-age

hi, filtering can be very confusing, perhaps this is what you want?

rclone touch hetznersbox01_sftp:minmax/2023-07-31 --localtime -t 2023-07-31T00:00:00.000 
rclone touch hetznersbox01_sftp:minmax/2023-08-15 --localtime -t 2023-08-15T00:00:00.000 
rclone touch hetznersbox01_sftp:minmax/2023-09-02 --localtime -t 2023-09-02T00:00:00.000 
rclone lsl hetznersbox01_sftp:minmax 
        0 2023-07-31 00:00:00.000000000 2023-07-31
        0 2023-08-15 00:00:00.000000000 2023-08-15
        0 2023-09-02 00:00:00.000000000 2023-09-02
rclone lsl hetznersbox01_sftp:minmax --max-age=2023-08-01 --min-age=2023-09-01 
        0 2023-08-15 00:00:00.000000000 2023-08-15

and a bit off-topic,
to enable checksum verification of transfers, use port = 23

type = sftp
host =
port = 23
key_file = c:\data\c\combined\hetzner\sbox\keys\id_ed25519
user = redacted
shell_type = unix
md5sum_command = md5 -r
sha1sum_command = sha1 -r

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.