Latest Synology Update removed Rclone

What is the problem you are having with rclone?

Rclone was removed during latest Synology Update -

Run the command 'rclone version' and share the full output of the command.

$ rclone version

rclone v1.63.0

  • os/version: unknown
  • os/kernel: 4.4.302+ (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.5
  • go/linking: static
  • go/tags: none

Are you on the latest version of rclone? You can validate by checking the version listed here: Rclone downloads
--> YES

Which cloud storage system are you using? (eg Google Drive)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount --daemon "boxdrive:" /volume1/homes/Tek9/Box --allow-other
2023/07/03 14:07:06 Fatal error: mount not ready

The rclone config contents with secrets removed.

type = box
token =

A log from the command with the -vv flag

Paste  log here

rclone has no connection to Synology. They are NAS appliance and any 3rd party software not officially supported by them can be removed/broken after update of DSM. You should ask on Synology forums how to fix it. rclone by itself does not prevent to be run on any system.

Maybe try the simplest way and reinstall it...

yeah, that is a known problem, and here was my workaround

based on that error, looks like rclone is installed.

this might be the issue. hard to know for sure, so next time run your commands with -vv for debug output, ok?
or maybe an issue with --daemon timeout

rclone mount --daemon "boxdrive:" /volume1/homes/Tek9/Box --allow-other -vv
2023/07/03 14:32:27 DEBUG : rclone: Version "v1.63.0" starting with parameters ["rclone" "mount" "--daemon" "boxdrive:" "/volume1/homes/Tek9/Box" "--allow-other" "-vv"]
2023/07/03 14:32:27 DEBUG : Creating backend with remote "boxdrive:"
2023/07/03 14:32:27 DEBUG : Using config file from "/var/services/homes/Tek9/.config/rclone/rclone.conf"
2023/07/03 14:33:27 DEBUG : Daemon timed out. Terminating daemon pid 31309
2023/07/03 14:33:27 Fatal error: mount not ready

remove --daemon, run the command again, post full output
or try increasing --daemon-wait

rclone mount "boxdrive:" /volume1/homes/tek9/Box --allow-other -vv
2023/07/03 15:25:38 DEBUG : rclone: Version "v1.63.0" starting with parameters ["rclone" "mount" "boxdrive:" "/volume1/homes/tek9/Box" "--allow-other" "-vv"]
2023/07/03 15:25:38 DEBUG : Creating backend with remote "boxdrive:"
2023/07/03 15:25:38 DEBUG : Using config file from "/var/services/homes/Tek9/.config/rclone/rclone.conf"
2023/07/03 15:25:38 INFO : box root '': poll-interval is not supported by this remote
2023/07/03 15:25:38 DEBUG : box root '': Mounting on "/volume1/homes/tek9/Box"
2023/07/03 15:25:38 Fatal error: failed to mount FUSE fs: fusermount: exec: "fusermount3": executable file not found in $PATH

the solution to that issue can be found in the link i shared up above.

looks like the symlink worked
ln -s /bin/fusermount /bin/fusermount3

I just tried that - THANK YOU - saved me big time

sure, welcome...

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.