Last file in an upload of multiple files takes an extremely long time? (R2)

Question: Is there a way to tell rclone "if an upload has not finished for an object, abort it, and retry"?


I'm guessing this is not an issue with rclone, rather it is an issue with R2, and I'd love to hear from other people on this forum using rclone + R2.

When doing a batch upload of files, often times the last file seems to be "stuck" when uploading. See:

Transferred:      146.271M / 146.271 MBytes, 100%, 2.600 MBytes/s, ETA 0s
Transferred:          161 / 162, 99%
Elapsed time:        56.9s
 *                          my_last_file.jpg:100% /24.872k, 261/s, 0s

I'm not sure how to interpret this output, has rclone finished uploading the file and is doing something else? What is going on?

Anyways, my solution is to just abort long uploads and retry them, so I'm trying to figure out how to tell rclone to do that.

Probably rclone is waiting for an acknowledgement from R2 that the file has been uploaded and it will timeout eventually (say after 5 minutes).

Got it. Is there some flag I can set to tell rclone to not wait for acknowledgements? As long as the file is probably uploaded, I don't care about the acknowledgement.

I ctrl-F for "acknowledge" in the global flags and found nothing relevant. I also ctrl-F's for --timeout and found a few things that might be relevant, just not sure what the precise flag to use is.

I'll also tag on that even when I use use --s3-disable-checksum, using the -vvvvvv flag, I still see the MD5 hashes of the files. Am I not using the correct flag to disable checksums?

It's probably waiting for a TCP acknowledgement. You can try experimenting with the --timeout flag, that might help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.