Just a noob looking for reassurance

What is the problem you are having with rclone?

I think I have it working correctly but I am unsure given my inexpedience with Linux.
I have the gdrive mounted and crypted, it works fine. I then created a local remote in rclone and mounted it to a local directory to shadow the cdrive (crypt remote of gdrive). I then mounted the union remote to the union directory and all three directories seem to me in sync but it gave me such a hassle that I wanted to ask if I should expect issues.

I am also planing on using:
rclone move ~/mylocal /mydata --no-transverse --transfers 50
in a cron every 2 hours

What is your rclone version (output from rclone version)

did not check to see if I could update the given version on the box

-rclone v1.53.3-DEV

  • os/arch: linux/amd64
  • go version: go1.15.5

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

This is what I used to mount all mounts, crypt, local (while in the crypt mount), and union.

rclone mount --daemon --daemon-timeout=5m --buffer-size=32M --dir-cache-time=84h --vfs-cache-mode=minimal --vfs-cache-max-age=6h remote: ~/mount/

The rclone config contents with secrets removed.

type = drive
client_id = 
client_secret = 
scope = drive
token =

type = crypt
remote = gdrive:~/mydata/
filename_encryption = standard
directory_name_encryption = true
password = 
password2 = 

type = union
upstreams = cdrive:/:nc ldrive:/mylocal

type = local

also seem to not be getting the backticks to work....

I would make the union point direct to the upstreams not via the mounts, so

should be

upstreams = gdrive:~/mydata/:nc /mylocal/

(assuming I've understood your config correctly).

That should work a whole lot better.

I fixed your post - the problem was that you had an unclosed HTML tag which was confusing things.

So the use of a local drive is acceptable? Is was mot sure exactly how they worked and frankly wondered if I even need the union after setting it up. The data and local directories seem to mirror each other and on top of that a certain program appears to not like the nc portion of the union so I did point it toward the local drive anyway. Do the local/data mirror work the way I think, is the union necessary?

Sorry read and responded in a rush while at work before. After getting home I was able to better understand and implement. I also realize why I had such issues with my previous setup. Thank you!

However, using the gdrive remote the union shows the encrypted files, as expected I imagine, but when I change the union to us the cdrive I do not see anything.

upstreams = cdrive:/:nc /mylocal/:RW
seems to be working

the cdrive:~/mydata/:nc part added a '~' direcctory to my mydata drive with a mydata directory in that.
man that not confusing to read...

I guess I tend to celebrate early, the cloud encrypted drive and the union drive seem to be good but there is no connection to the local drive.

I think this syntax is wrong - remove the :RW

If you run rclone lsf -vv udrive: you'll see in the debug messages the backends created - check these look sensible

OMG no wonder I was felt like I was beating my head against a wall. As soon as it occurred to me to use the full path everything fell into place. Being new to Linux and on a headless shared machine is a hell of a handicap. I case someone else happens to be like me and looking I wanted to put my solution up.
my current config file looks like this:

type = drive
client_id = 
client_secret = 
scope = drive
token =

type = union
upstreams = gdrive:/:nc /mnt/mpath/usernam/localdrive/ 

I did ditch the encryption but I have no reason to believe that was part of my issue as the crypt drive worked. I do not know why ~/localdrive/ did not work but I have a whole 2 weeks on Linux under my belt. Thank you for your help Nick!

Glad you fixed it.

I assumed you were shortening the paths for privacy reasons - sorry!

Generaly speaking the ~ is interpreted by the shell (try echo ~) just like * - so you can't put it into config files unless the program has specific support for it which rclone doesn't in this case (but it does support it in some places!).

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.