Jottacloud & Plex

Hi Everyone,

I would like to use my jottacloud service as a PLEX library, but being fairly new at this and I cannot manage alone. I would like to mention that I used the Google Drive instructions up to a point.

I am using rclone v1.53.1 on unbuntuDDE 20.04 (first time on Linux). I managed so far to create a new remote. I then used the command "rclone lsd remote:" which showed me my Archive folders accordingly.
At this point I typed in the following:
###alegri@UDDE-t200tac:~$ sudo mkdir /opt/rclone/
alegri@UDDE-t200tac:~$ sudo cp ~/.config/rclone/rclone.conf /opt/rclone/rclone.conf
alegri@UDDE-t200tac:~$ sudo cat /opt/rclone/rclone.conf
type = jottacloud
tokenURL = "edited"
token = "edited"
device = Jotta
mountpoint = Archive
configVersion = 1
alegri@UDDE-t200tac:~$ cd /etc/systemd/system/
alegri@UDDE-t200tac:/etc/systemd/system$ ls
dbus-fi.w1.wpa_supplicant1.service oem-config.service.wants
dbus-org.freedesktop.nm-dispatcher.service samba-ad-dc.service
dbus-org.freedesktop.thermald.service snap.canonical-livepatch.canonical-livepatchd.service
dbus-org.freedesktop.timesync1.service 'snap-canonical\x2dlivepatch-95.mount' snap-core-9804.mount
display-manager.service snap-core-9993.mount
display-manager.service.wants syslog.service systemd-resolved.service.wants
alegri@UDDE-t200tac:/etc/systemd/system$ sudo nano teliasky-rclone.service###

From here on I cannot seem to understand exactly what I have to do.
I tried the command: rclone mount teliasky: /home/Cloud (I renamed the remote to teliasky - don't know if it is relevant), but it returns "fatal error: Can not open: /home/Cloud: open /home/Cloud: no such file or directory", even though the directory exists.

Can anybody share some thoughts?

What happens when you do

ls /home/Cloud

Does that work?

Nope. I get:
"ls: cannot access '/home/Cloud': No such file or directory"

Meanwhile I did this:

alegri@UDDE-t200tac:~$ sudo mkdir /home/Cloud
alegri@UDDE-t200tac:~$ ls /home/Cloud
alegri@UDDE-t200tac:~$ rclone mount teliasky: /home/Cloud --vfs-cache-mode full
2020/09/17 23:57:01 mount helper error: fusermount: user has no write access to mountpoint /home/Cloud
2020/09/17 23:57:01 Fatal error: failed to mount FUSE fs: fusermount: exit status 1
alegri@UDDE-t200tac:~$ sudo rclone mount teliasky: /home/Cloud --vfs-cache-mode full
2020/09/17 23:57:17 NOTICE: Config file "/root/.config/rclone/rclone.conf" not found - using defaults
2020/09/17 23:57:17 Failed to create file system for "teliasky:": didn't find section in config file

What does this error mean?

This creates a folder owned by root.

You tried to mount a folder owned by root as your regular user and got a permission error.

This means you probably ran rclone config as one user and root has no config file because it was run as another user.

You want to use the same regular user through the whole process.

Okay. Thanks for the input. Now I am even more confused than before )

The folder should be owned by root or user?
If I just use the command "mkdir /home/Cloud", I get the output below:
"mkdir: cannot create directory '/home/Cloud': File exists"
The same output when I run "sudo mkdir /home/Cloud".
In my understanding this means that I have the same folder owned both by root and user, correct?
I used "sudo rmdir /home/Cloud" to remove the folder and start from scratch. The same command without sudo resulted in fail to remove error "Permission denied".

I also deleted the remote:

alegri@UDDE-t200tac:~$ rclone config edit
Current remotes:

Name Type
==== ====
teliasky jottacloud

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config
e/n/d/r/c/s/q> d
Choose a number from below, or type in an existing value
1 > teliasky
remote> 1
No remotes found - make a new one
n) New remote
s) Set configuration password
q) Quit config
n/s/q> q

Followed by:

alegri@UDDE-t200tac:~$ rclone config delete teliasky
alegri@UDDE-t200tac:~$ rclone config delete teliasky-rclone.service
alegri@UDDE-t200tac:~$ sudo rm -rf /opt/rclone

Now to start over. I will create a new remote. That is the easy part. What should be the next steps afterwards, and how should I configure the rclone.service in order to be able to mount the Archive in Plex. My Jottacloud has the following folders on the root:

  1. Synced
  2. Backup
  3. Archive
  4. Shared

What I m trying to mount is a folder called Collection inside the Archive folder.

Very much appreciate the input!

I don't know as that's really a question you'd have to answer on how you want to set things up. I don't run things as root as it's generally bad practice.

That's because the directory already exists. Normally in Linux, you create a user and use that user. Since you deleted/removed the Help Template that collects all the relevant information, I'm not sure exactly what you are running.

In Linux, a file or directory is only ever owned by one user but you can give permission to other groups or allow anyone to have access.

I'm sorry but I'm having a hard time following what user you are using and your directory stucture.

Normally in Linux, you have a user. That user has a home location say user1 and that would be /home/user1

User1 would log in and create any directories in their existing home drive and run rclone config and mount things that way if you wanted to use the /home location for things.

In the end, I don't think Jottacloud works that well with Plex so not sure it's worth the effort. Perhaps other folks that use Jottacloud could comment though before you go through all the effort and it doesn't perform well enough to stream.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.