Jottacloud Legacy mode isn't working: Reveal failed

What is the problem you are having with rclone?

Jottacloud in legacy mode, bought through Elkjøp, isn't working. The error message shown is: Reveal failed: input too short when revealing password - is it obscured?

Run the command 'rclone version' and share the full output of the command.

rclone v1.64.0

  • os/version: arch "rolling" (64 bit)
  • os/kernel: 6.5.9-273-tkg-bore-eevdf (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.1
  • go/linking: dynamic
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Jottacloud in legacy mode through Elkjøp Cloud

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copyto ./testfile.sh elkjopcloud:test

The rclone config contents with secrets removed.

type = local
skip_links = true

[elkjopcloud]
type = jottacloud
md5_memory_limit = 16Gi
configVersion = 0
username = mail@mail.com
password = I tried both the real password for my cloud and using an obscure one created using: rclone obscure myrealpassword
auth_code =

A log from the command with the -vv flag

<7>DEBUG : rclone: Version "v1.64.0" starting with parameters ["rclone" "-vv" "copyto" "./test.sh" "elkjopcloud:test"]
<7>DEBUG : rclone: systemd logging support activated
<7>DEBUG : Creating backend with remote "./test.sh"
<7>DEBUG : Using config file from "/home/x/.config/rclone/rclone.conf"
<7>DEBUG : fs cache: adding new entry for parent of "./test.sh "/home/x"
<7>DEBUG : Creating backend with remote "elkjopcloud:"
Reveal failed: input too short when revealing password - is it obscured?

I had this running without any issues up until around a month ago when my harddrive crashed and I had to recreate the config file. No matter what I try, it ends in the error above and won't accept my cloud password. Am I doing something wrong here or is this a bug?

welcome to the forum,

please update and test again
rclone selfupdate

Same error. I also tried the latest git with the same result

that is a very basic function of rclone, should have nothing to do with jottacloud or any other remote.
so i would double check that. maybe a copy/paste mistake.

I can try to see if it works if I reset it, but before I do that I just want to know for sure: Assuming my password to the cloud account is abc123, is this the password I put in rclone.conf:

password = abc123

Or am I supposed fo first do:

rclone obscure abc123

And use this as a password in rclone.conf?

password = xAVr4m9_Su4nWKzDCey_3W0SrI24uQ

correct, rclone obscures passwords.

Nope, didn't work. :frowning:

Still shows up the same error. I tried using both the actual cloud password in rclone.conf and the obscured one created by using rclone obscure.

I also tried reconfiguring it by using rclone config, with the same result. :frowning:

https://github.com/rclone/rclone/issues/4299

there is no password option in jottacloud config. I think you manually inserted it - it is not needed.

It is also mentioned during configuration process.

Option config_password.
Password (only used in setup, will not be stored)
Choose an alternative below. Press Enter for the default (n).
y) Yes, type in my own password
g) Generate random password
n) No, leave this optional password blank (default)
y/g/n> y
Enter the password:

What you have to do for legacy setup is choose config_type 2, provide email and password (your actual password not obfuscated one).

Option config_type.
Select authentication type.
Choose a number from below, or type in an existing string value.
Press Enter for the default (standard).
   / Standard authentication.
 1 | Use this if you're a normal Jottacloud user.
   \ (standard)
   / Legacy authentication.
 2 | This is only required for certain whitelabel versions of Jottacloud and not recommended for normal users.
   \ (legacy)
   / Telia Cloud authentication.
 3 | Use this if you are using Telia Cloud (Sweden).
   \ (telia_se)
   / Telia Sky authentication.
 4 | Use this if you are using Telia Sky (Norway).
   \ (telia_no)
   / Tele2 Cloud authentication.
 5 | Use this if you are using Tele2 Cloud.
   \ (tele2)
   / Onlime Cloud authentication.
 6 | Use this if you are using Onlime Cloud.
   \ (onlime)
config_type> 2

Do you want to create a machine specific API key?

Rclone has it's own Jottacloud API KEY which works fine as long as one
only uses rclone on a single machine. When you want to use rclone with
this account on more than one machine it's recommended to create a
machine specific API key. These keys can NOT be shared between
machines.
y) Yes
n) No (default)
y/n>

Option config_username.
Username (e-mail address)
Enter a value.
config_username> test@test.com

Option config_password.
Password (only used in setup, will not be stored)
Choose an alternative below. Press Enter for the default (n).
y) Yes, type in my own password
g) Generate random password
n) No, leave this optional password blank (default)
y/g/n> y
Enter the password:
password:
Confirm the password:
password:

I suggest you create a new remote from the scratch.

when the setup asks for legacy authentication and enter your username and password

That one is from 2020, I've had rclone working just fine before my harddrive crashed and my config file disappeared around 2 months ago.

The irony is not lost on me that I had a full backup of everything except the ~/.config directory. :slight_smile:

I just tried it a third time, by deleting rclone.conf and reconfiguring from scratch using rclone config. And I still get the same error. :frowning:

I managed get it working, it was a configuration error.

The solution is to answer YES to the question "Do you want to create a machine specific API key?"

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.