It's possible on Android?

Is there any way to install rclone (and mount option) in a rooted Android?


You can use rclone with termux - see here for how to compile it…

mount may work too in a rooted android - I don’t know!

I put a page in the wiki:

Thanks a lot!!

I compiled it and it shows the version, but I don’t know how to find the binary and how are the tree directories to mount it :((

When I try to mount I get this error:

Fatal error: failed to mount FUSE fs: fusermount: exec: “fusermount”: executable file not found in $PATH

Here is a chat which seems to indicate that termux doesn’t support fusermount.

However if you have root, you can install a full debian chroot which might support it.

I did successfully do this in a chroot environment.

@nodesyn care to share how did you do this? I’ve tried on a debian chroot, it mounted, but it wasn’t visible in other apps, for example: kodi.

How did you do it? :slight_smile:

@fneves, would you mind explaining how you mounted it and on which device?

I tried it on my Nexus 4 using Termux but I wasn’t even able to mount it on the Nexus because of the missing FUSE module.

What you can do is use this idea with kodi. It will spawn a http webserver and then you can point kodi against it.

this is a noob question but what directory should I be in when I start entering all the commands?

I have Termux on my unrooted Android phone

following here:

I just started in whatever directory Termux had me in

I think this was:

so now rclone seems to be under:

did I mess up?

No that looks right (for termux).

Either put that directory on the path, or copy the rclone binary to something which is on the path.

@ncw could you explain how I would do that please? (sorry to take up your time)

edit: if I run
$ ./rclone help
I see that the directory the config will be saved in is:
(not sure if this helps)

Copy the binary to /data/data/com.termux/files/usr/bin

so cp -a rclone /data/data/com.termux/files/usr/bin/ should do it.

1 Like