Issues with SFTP due to GO's security restrictions

I’ve recently tried to set up an SFTP remote but uppon cloning I get an error. I ran the following command
sudo rclone sync bgp-router00-van:/etc/bird/communities.conf /usr/local/etc/communities.conf -vv (where bgp-router00-van is the name of my remote) and got the following output

2019/04/24 01:42:04 DEBUG : rclone: Version "v1.36" starting with parameters ["rclone" "sync" "bgp-router00-van:/etc/bird/communities.conf" "/usr/local/etc/communities.conf" "-vv"]

2019/04/24 01:42:04 Failed to create file system for "bgp-router00-van:/etc/bird/communities.conf": couldn't connect ssh: ssh: must specify HostKeyCallback

It appears that this is for the reason specified here: but I am unsure on how that would be fixed on my end. Let me know if there is anything that I can do. I will provide my config file below in case that helps. I tried searching the forum but came up with nothing related to HostKeyCallback

type = drive
client_id = 
client_secret = 
token = # perhaps these tokens are important so I removed them
type = sftp
host =
user = bryce
port = 22
pass = # Encrypted password here

What happens if you try to run it with --sftp-ask-password instead (might need to remove the one from the config)

It was fixed in May 2017 but the 1.36 is ancient.

Grab the latest and try again.

What would be the best way to get the latest? I have the latest available in Ubuntu 18.04’s repositories (though I do know that they are known for often having older versions). Do you happen to know of another repository that has a newer version that I can pin it to, maybe the Debian repositories?

Why not just clone the git repo and build from source? If you install it that way, it shouldn’t mess with the version provided by the repositories (it will install into /usr/local/ by default, I believe).

(by the way, Debian unstable only has 1.45 - I might end up taking my own advice, since I have no idea when it will be updated…probably after the Buster release?)

Uninstall whatever version you have and just run from the page. Any repo usually is much outdated and I wouldn’t grab it from there.

curl | sudo bash

I wouldn’t recommend building from source as you really want the released versions to keep consistent and it’s just easier too.

I generally like to stick to packages being managed by a package manager for dependency management easier clean up if I need to uninstall. It’s also easier to automate since I have multiple servers that all have the same config. I wish that apt was like brew on macOS where manual packages are much easier to add. I suppose that I can concede. I do already have to deal with installing Bird 2.0 from source so installing one thing manually it not the end of the world.

You can find .deb and .rpm packages for rclone here

As ncw noted, the packages for deb and such are there, but I think that’s pretty much overkill as rclone is really 1 binary :slight_smile:

Did you happen to get the latest version and see if that fixes your issue?

I was updating some other packages and then had work so I have not tried it yet however I am about to do that now. I presume that I will work as evidenced from the solved bug report linked above and my understanding of the cause of the issue.

It looks like it has been successful!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.