Issues with rclone after system update

What is the problem you are having with rclone?

Unable to access/read files after system update (ubuntu impish to 22.10)

Run the command 'rclone version' and share the full output of the command.

ldr@lui-server:/$ rclone version
rclone v1.53.3-DEV

  • os/arch: linux/amd64
  • go version: go1.18

Which cloud storage system are you using?

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount:


Description=Mount and cache Google drive to /mnt/plexclouddrive
ExecStartPre=/bin/mkdir -p /mnt/plexclouddrive
ExecStartPre=/bin/mkdir -p /var/log/rclone
ExecStartPre=/bin/mkdir -p /mnt/rclonecache
ExecStart=/usr/bin/rclone mount \
  --rc \
  --log-file /var/log/rclone/rclone.log \
  --log-level DEBUG \
  --umask 000 \
  --allow-non-empty \
  --allow-other \
  --tpslimit 10 \
  --tpslimit-burst 10 \
  --dir-cache-time=160h \
  --buffer-size=64M \
  --attr-timeout=1s \
  --vfs-read-chunk-size=2M \
  --vfs-read-chunk-size-limit=2G \
  --vfs-cache-max-age=6h \
  --vfs-cache-max-size 50G \
  --vfs-cache-mode=full \
  --vfs-cache-poll-interval 5m \
  --cache-dir /mnt/rclonecache \
  --config /home/rclone/rclone.conf \
  Gcrypt: /mnt/plexclouddrive
ExecStop=/bin/fusermount -u -z /mnt/plexclouddrive
ExecStop=/bin/rmdir /mnt/plexclouddrive

mounting seems to run fine and the directory becomes available, I can list files. rclone ls also shows everything just fine. But when trying to access the files i get errors like:

2023/01/20 15:55:01 ERROR : worker-0 <phkv5ese53oedliijnot5sjstkofp4rn8qiu9946l5gr7tm0239ggqutu8rq9u7usccs95pe63u5q6k67vdqqm1tkmehha58fakho6g>: object open failed 0: rate: Wait(n=1) would exceed context deadline

The rclone config contents with secrets removed.

type = drive
client_id =
client_secret = QepCeBAQiGXFPfSZGrTSHkx9
scope = drive
token = {"access_token":"ya29.a0AX9GBdUWEf7gyl8RlcoDW6JGgDDuWch8TQshM_aFIp1H-Pv00_SNFdYS2juFXYRYdvPIHG8iSYP2tHQJQrJJnHvwo-rBn5eZt1VnKeyFEg61e2FKREca5jF-Fk-a2N4I33VfHOuwmfhNbBaLLncEee3zUqK5CY0ZdQaCgYKAZMSAQASFQHUCsbC1kkD0RPErUgg_NwOMVcGYw0169","token_type":"Bearer","refresh_token":"1//09u4F-fFu6a0YCgYIARAAGAkSNwF-L9Irz1HCkjLcLCwATt6csFWSsUchwuaNLFpXjBUDs5uBv56rk_m86gnbPvmoYhHwNJKKUhI","expiry":"2023-01-20T16:02:12.416932334+01:00"}
root_folder_id = 0ANCNmh8fHm_jUk9PVA

type = crypt
remote = Gcache:/crypt
filename_encryption = standard
directory_name_encryption = true
password = removed
password2 = removed

type = crypt
remote = Gdrive:/gdrive/crypt
filename_encryption = standard
directory_name_encryption = true
password = removed
password2 = removed

type = cache
remote = Gdrive:/gdrive
plex_url = http://localhost:32400
plex_username = removed
plex_password = removed
chunk_size = 10M
info_age = 1d
chunk_total_size = 10G
plex_token = UMLZyQQUeieb5a-kKLdk

A log from the command with the -vv flag

Debug log (start, try to open file)

hello and welcome to the forum,

that version of rclone is very old, can get the latest stable at

also, for Gcache, the cache backend has been deprecated, not needed for plex
from the docs,
"it currently doesn't have a maintainer so there are outstanding bugs which aren't getting fixed."

with a minor change to the config file, should be easy to remove it.

Thanks asdffdsa!

Just updated to latest, and this seems to have fixed it, I am however as you also state, getting a warning about the Cache:

2023/01/20 18:40:05 NOTICE: WARNING: Cache backend is deprecated and may be removed in future. Please use VFS instead.

Since I already have vfs-cache settings in my mount, I assume I should simply point the Gcrypt directly to the Gdrive? I will play around with that.

For now thanks, and sorry, should have tried this before posting!

that is correct, something like this, you need to verify
remote = Gcache:/crypt
remote = Gdrive:gdrive/crypt

and this is a systemd service file, for gdrive and plex.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.