Is this mount command OK?

#1

Hi,

I currently use Rclone to mount my Google drive to use with Plex, this is the command I use:

rclone mount --allow-other --allow-non-empty --dir-cache-time 48h --vfs-cache-max-age 48h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 4G --buffer-size 0M --umask 002 --cache-db-purge drive: /mnt/drive &

Videos load up quick but I do have a strange issue of that sometimes after 20 minutes the videos just stop and go back to the movie information screen but when I hit play it starts playing again?

Just wanted to make sure I am using a correct mount command.

Thanks.

#2

You have some things in there that don’t matter as I think you are using the cache backend?

Allow-non-Empty allows for over mounting and hides things. I avoid like the plague.

Any of the VFS options aren’t needed if you are using the cache.

If you out the mount in debug with -vv and share the log when the error happens, we can see if rclone is the issue.

#3

rclone mount --allow-other --dir-cache-time 48h --vfs-cache-max-age 48h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 4G --buffer-size 0M --umask 002 --cache-db-purge -vv drive: /mnt/drive &

Shall I mount it like this? I have removed 'allow-non-empty' and added '-vv' at the end.

#4

If you are using the cache backend, all that stuff is not needed.

#5

Sorry forgot to mention I am not using a cache drive.

#6

isn't needed as I would still remove all those items as the defaults are better values.

#7

So if I remove the VFS options it will just use the default VFS values?

#8

is just about all you need.

#9

So does that still cache data locally?

#10

The cache backend is the only thing that stores thing locally.

#11

Do you think it's worth creating a cache backend?

#12

Me personally? No, I have no use case for it. Depends on what you are doing/trying to achieve.

I stream Plex for my major use case and folks rarely play the same thing again so keeping anything local makes no sense for me.

#13

Me and about 4 people are just streaming using Plex.

If you think that will suffice I will just use what you said.

#14

Should be just fine for that.

Make sure you setup your own client ID/API key if you haven't.

https://rclone.org/drive/#making-your-own-client-id

That helps more than just about anything else you could possibly do.

#15

Thanks for the info Animosity022, really appreciate it.

#16

I tried the above command but almost immediately everything just slowed down and stopped loading. When I ran the command - 'rclone lsd drive:', it complained about exceeding GoogleAPI limit but when I ran it again it showed my directories.

I don't think I went over my limit:

When I changed back to my original mount command it was same thing slow loading/not loading at all.

I unmounted using the command 'fusermount -u /path/to/drive' is this correct to unmount because it looked like it was loading back up when I ran my original mount? Can I see which mount I am using?

EDIT:

Just tried the rclone lsd drive: command again and this is the error that pops up:

2019/05/15 08:27:33 ERROR : : error listing: couldn't list directory: googleapi: Error 429: Rate Limit Exceeded, rateLimitExceeded
2019/05/15 08:27:33 Failed to lsd: couldn't list directory: googleapi: Error 429: Rate Limit Exceeded, rateLimitExceeded

Edit: Just seen other people are having same issue with this error on the Rclone forum.

#17

I have written this in the main 429 error thread but I think it will get lost in there.

Basically I have mounted by Rclone with the user string but even though every now loads OK through Plex randomly after about 20 mins things freeze and I have to restart Plex to get it working again and I still see 40-60% errors on my API graph. Do people still see errors?

#18

Nope. No errors since adding the useragent string for me:

I'm in the US if that matters.

My mount is just this:

felix     4466     1  1 07:15 ?        00:19:02 /usr/bin/rclone mount gcrypt: /GD --allow-other --dir-cache-time 96h --log-level INFO --log-file /opt/rclone/logs/rclone.log --timeout 1h --umask 002 --user-agent someappname --rc
#19

Hmm...this is the mount command I am using basically what you suggested earlier on but with the user string:

rclone mount --allow-other --dir-cache-time 48h --log-level INFO --log-file /home/seed/logs/rclone.log videodrive: /mnt/videodrive --user-agent='Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36': &

#20

Are you sure it's actually picking up the user-agent setting and some old process isn't running?

You can check with a ps -ef | grep rclone

and see what it is running as.