Is there a way to get rclone copy to preserve metadata?

I'm planning to backup my s3 buckets on Azure and so far rclone works great but when i went to examine my s3 object i found this:

System defined	Content-Disposition	inline; filename=monkey-business-example.jpg
System defined	Content-Type	image/jpeg

and in my Azure blob I get this:

CONTENT-TYPE	application/octet-stream

Is there a way to get rclone copy to preserve metadata when going from s3 to Azure?

My rclone version is:

rclone v1.53.3
- os/arch: linux/amd64
- go version: go1.15.5

Not currently is the answer.

This is this issue

What metadata in particular are you interested in? Rclone should preserve the content type though - I'm surprised that isn't preserved.

How exactly did you do the copy?

I ran the following:

rclone copy S3:local-test/images AZURE:tempcontainer --progress -vv --transfers=1

The config was basic just the bare minimum necessary to do the transfer type, account id, secret key.

Hmm, I think this is a bug in the azureblob backend - it isn't setting the mime types from the source properly

Can you have a go with this please?

v1.54.0-beta.4924.9b6c33595.fix-mimetype on branch fix-mimetype (uploaded in 15-30 mins)

It works! Thanks.

Thanks for testing!

This bug has been in rclone for a long time so I'm really glad you reported it.

I've merged this to master now which means it will be in the latest beta in 15-30 mins and released in v1.54

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.